aboutsummaryrefslogtreecommitdiff
path: root/net-im/jarl/Makefile
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2002-11-10 17:23:52 +0000
committerDima Dorfman <dd@FreeBSD.org>2002-11-10 17:23:52 +0000
commitf66b7b2e41e7850d743ddf94aa096847ca7b2f13 (patch)
treea4983f50225ebc5050626f6389e1431534dcd609 /net-im/jarl/Makefile
parent26b57800ed37bea20d160b656d81881a06ade816 (diff)
Notes
Diffstat (limited to 'net-im/jarl/Makefile')
-rw-r--r--net-im/jarl/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-im/jarl/Makefile b/net-im/jarl/Makefile
new file mode 100644
index 000000000000..a7eb2496d94e
--- /dev/null
+++ b/net-im/jarl/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: jarl
+# Date created: 10 November 2002
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= jarl
+PORTVERSION= 0.5001
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Jarl-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ptksh:${PORTSDIR}/x11-toolkits/p5-Tk \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Jabber/IQ.pm:${PORTSDIR}/net/p5-Net-Jabber
+
+NO_BUILD= yes
+
+USE_REINPLACE= yes
+USE_PERL5= yes
+
+makeplist:
+ ${ECHO} bin/jarl > ${PLIST}
+ ${FIND} ${PREFIX}/share/jarl -type f -print | ${CUT} -d/ -f4- >> \
+ ${PLIST}
+ ${FIND} ${PREFIX}/share/jarl -type d -print | ${CUT} -d/ -f4- | \
+ sort -r | ${SED} 's/^/@dirrm /' >> ${PLIST}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/jarl
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/jarl
+ ${INSTALL_SCRIPT} ${WRKSRC}/jarl ${PREFIX}/bin
+ cd ${WRKSRC} && ${FIND} lib bitmaps -type d -print | while read d; do \
+ ${MKDIR} ${PREFIX}/share/jarl/$$d; \
+ ${FIND} $$d -maxdepth 1 -type f -print | \
+ ${XARGS} -t -J% ${INSTALL_DATA} % \
+ ${PREFIX}/share/jarl/$$d; \
+ done;
+
+.include <bsd.port.mk>