aboutsummaryrefslogtreecommitdiff
path: root/net-im/jit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-31 13:08:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-31 13:08:22 +0000
commitd725436197c4e322c9ae7c6c634706b90d04219d (patch)
tree01d7872319a62738cb70414f4202231119339d3f /net-im/jit
parent5486dda5b2da224ef76882aad25f915edc8b5135 (diff)
downloadports-d725436197c4e322c9ae7c6c634706b90d04219d.tar.gz
ports-d725436197c4e322c9ae7c6c634706b90d04219d.zip
Notes
Diffstat (limited to 'net-im/jit')
-rw-r--r--net-im/jit/Makefile8
-rw-r--r--net-im/jit/files/patch-jit-jit-wp_client.cpp63
2 files changed, 64 insertions, 7 deletions
diff --git a/net-im/jit/Makefile b/net-im/jit/Makefile
index 56d0e2e490e9..21a5930fb27e 100644
--- a/net-im/jit/Makefile
+++ b/net-im/jit/Makefile
@@ -22,12 +22,6 @@ CFLAGS+= -fPIC
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/jit/jabber-icq.example
@@ -42,4 +36,4 @@ do-install:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/jit/files/patch-jit-jit-wp_client.cpp b/net-im/jit/files/patch-jit-jit-wp_client.cpp
new file mode 100644
index 000000000000..9865ac18da53
--- /dev/null
+++ b/net-im/jit/files/patch-jit-jit-wp_client.cpp
@@ -0,0 +1,63 @@
+--- jit/jit/wp_client.cpp.orig 2004-11-10 18:23:27.000000000 +0000
++++ jit/jit/wp_client.cpp 2007-10-31 03:39:39.000000000 +0000
+@@ -152,22 +152,31 @@
+
+ switch(ev->getReason()){
+ case DisconnectedEvent::FAILED_BADUSERNAME:
++ {
+ e = (terror){400,"Bad username"};
++ }
+ break;
+
+ case DisconnectedEvent::FAILED_TURBOING:
++ {
+ e = (terror){503,"Turboing, connect later"};
++ }
+ break;
+
+ case DisconnectedEvent::FAILED_BADPASSWORD:
++ {
+ e = (terror){400,"Bad (non mismatched) registration password"};
++ }
+ break;
+
+ case DisconnectedEvent::FAILED_MISMATCH_PASSWD:
++ {
+ e = (terror){401,"Password does not match"};
++ }
+ break;
+
+ case DisconnectedEvent::FAILED_DUALLOGIN: {
++ {
+ /* maybe we should explicitly notify due importance */
+ char *body=LNG_DUAL_LOGIN;
+
+@@ -180,21 +189,28 @@
+ it_deliver(sesja->ti,msg);
+
+ e = (terror){409,"Dual login"};
++ }
+ break;
+ }
+
+ case DisconnectedEvent::FAILED_LOWLEVEL:
++ {
+ e = (terror){502,"Low level network error"};
++ }
+ break;
+
+ case DisconnectedEvent::REQUESTED:
++ {
+ log_debug(ZONE,"Disconnected on request");
+ e = (terror){0,""};
++ }
+ break;
+
+ case DisconnectedEvent::FAILED_UNKNOWN:
+ default:
++ {
+ e = (terror){502,"Disconnected by unknown reason"};
++ }
+ break;
+ }
+