aboutsummaryrefslogtreecommitdiff
path: root/net-im/kopete
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-11-04 07:26:24 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-11-04 07:26:24 +0000
commit7670739362e0c031545a5c0ff4b2c12ff0a87c63 (patch)
tree58f6f4870a821286974eb33d6e11fc18cfb88071 /net-im/kopete
parent060143bca46d4b157a8a16986751e5d0e770d180 (diff)
downloadports-7670739362e0c031545a5c0ff4b2c12ff0a87c63.tar.gz
ports-7670739362e0c031545a5c0ff4b2c12ff0a87c63.zip
Notes
Diffstat (limited to 'net-im/kopete')
-rw-r--r--net-im/kopete/Makefile2
-rw-r--r--net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index a7fbd97fd8a8..df0ae0ca1f1b 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kopete
PORTVERSION= 0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= net-im kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/3.5.4/src
diff --git a/net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp b/net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp
new file mode 100644
index 000000000000..c475926d6372
--- /dev/null
+++ b/net-im/kopete/files/patch-kopete_protocols_oscar_liboscar-client.cpp
@@ -0,0 +1,10 @@
+--- kopete/protocols/oscar/liboscar/client.cpp 2006/08/17 13:37:13
++++ kopete/protocols/oscar/liboscar/client.cpp 2006/10/31 18:48:12
+@@ -340,6 +340,7 @@
+ //we've finished logging in. start the services setup
+ kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
+ initializeStaticTasks();
++ d->ownStatusTask->go();
+ ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
+ connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
+ ssTask->go( true ); //fire and forget