aboutsummaryrefslogtreecommitdiff
path: root/net-im/ktp-text-ui
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-01-14 11:27:06 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-01-14 11:27:06 +0000
commit66686f4d261ceb373306069cb7e9358bbfdb1797 (patch)
tree23c5e5bc6cc06a6fc795d5b274a22ec0e71b0dd9 /net-im/ktp-text-ui
parent6a99c4d3352a26ced5a5d0a8137adbc46a9d7a0a (diff)
Notes
Diffstat (limited to 'net-im/ktp-text-ui')
-rw-r--r--net-im/ktp-text-ui/Makefile2
-rw-r--r--net-im/ktp-text-ui/files/patch-lib__adium-theme-view.cpp22
2 files changed, 1 insertions, 23 deletions
diff --git a/net-im/ktp-text-ui/Makefile b/net-im/ktp-text-ui/Makefile
index 944c565c8887..5ff871624d36 100644
--- a/net-im/ktp-text-ui/Makefile
+++ b/net-im/ktp-text-ui/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${KDE4_PREFIX}/bin/ktp-contactlist:${PORTSDIR}/net-im/ktp-contact-l
USE_KDE4= kdeprefix automoc4
USE_QT4= corelib webkit xml \
moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
+USES= cmake compiler:c++11-lang gettext tar:bzip2
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/net-im/ktp-text-ui/files/patch-lib__adium-theme-view.cpp b/net-im/ktp-text-ui/files/patch-lib__adium-theme-view.cpp
deleted file mode 100644
index daffe505225b..000000000000
--- a/net-im/ktp-text-ui/files/patch-lib__adium-theme-view.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./lib/adium-theme-view.cpp.orig 2013-04-16 19:00:42.000000000 +0200
-+++ ./lib/adium-theme-view.cpp 2013-05-02 01:58:37.569417377 +0200
-@@ -165,7 +165,8 @@
- QString footerHtml = replaceHeaderKeywords(m_chatStyle->getFooterHtml(), chatInfo);
- QString extraStyleHtml = m_chatStyle->messageViewVersion() < 3 ? QLatin1String("")
- : QLatin1String("@import url( \"main.css\" );");
-- m_lastContent = AdiumThemeContentInfo();
-+ AdiumThemeContentInfo message;
-+ m_lastContent = message;
-
- if (templateHtml.isEmpty()) {
- // if templateHtml is empty, we failed to load the fallback template file
-@@ -427,7 +428,8 @@
- message.appendMessageClass(QLatin1String("consecutive"));
- }
-
-- m_lastContent = AdiumThemeContentInfo(statusMessage.type());
-+ AdiumThemeContentInfo message2(statusMessage.type());
-+ m_lastContent = message2;
-
- switch (message.type()) {
- case AdiumThemeMessageInfo::Status: