aboutsummaryrefslogtreecommitdiff
path: root/net-im/libjingle
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-12-30 05:32:18 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-12-30 05:32:18 +0000
commitf2fce843c01048e32848072de0b4b88c73b46317 (patch)
treeeefa5d5ea8c9a8880048af81015b6f104de1fcf8 /net-im/libjingle
parentf3e2cabd0dfa277d1cbe5a0df5ba6b52f3842c7a (diff)
downloadports-f2fce843c01048e32848072de0b4b88c73b46317.tar.gz
ports-f2fce843c01048e32848072de0b4b88c73b46317.zip
Notes
Diffstat (limited to 'net-im/libjingle')
-rw-r--r--net-im/libjingle/Makefile40
-rw-r--r--net-im/libjingle/files/patch-talk__session__fileshare__fileshare.cc13
2 files changed, 26 insertions, 27 deletions
diff --git a/net-im/libjingle/Makefile b/net-im/libjingle/Makefile
index 13307f52a47e..ff20a784bfb8 100644
--- a/net-im/libjingle/Makefile
+++ b/net-im/libjingle/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libjingle
-# Date created: Wed Feb 22 01:33:20 UTC 2006
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libjingle
PORTVERSION= 0.4.0
@@ -14,10 +10,10 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Google Talk's implementation of Jingle and Jingle-Audio
-LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
- ilbc.0:${PORTSDIR}/net/ilbc \
- ortp.8:${PORTSDIR}/net/linphone-base \
- expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= speex:${PORTSDIR}/audio/speex \
+ ilbc:${PORTSDIR}/net/ilbc \
+ ortp:${PORTSDIR}/net/linphone-base \
+ expat:${PORTSDIR}/textproc/expat2
CONFLICTS= krb4-[0-9]* krb5-[0-9]* heimdal-[0-9]* srp-[0-9]* \
clusterit-[0-9]* pcp-[0-9]* synce-librapi2-[0-9]*
@@ -42,22 +38,21 @@ CONFIGURE_ENV= PKG_CONFIG="${PKG_CONFIG}" \
SPEEX_LIBS="$$(${PKG_CONFIG} --libs speex)"
CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC} ${PTHREAD_CFLAGS} -g
MAKE_JOBS_SAFE= yes
+LDFLAGS+=-L${LOCALBASE}/lib -L${OPENSSLLIB} ${PTHREAD_LIBS}
-DOC_FILES= AUTHORS \
+PORTDOCS= AUTHORS \
ChangeLog \
DOCUMENTATION \
NEWS \
README
-.ifndef(NOPORTDOCS)
-PORTDOCS= ${DOC_FILES}
-.endif
-
PLIST_FILES+= bin/login \
bin/pcp \
bin/relayserver \
bin/stunserver \
+.include <bsd.port.options.mk>
+
post-configure:
# force glib
# force ilbc
@@ -79,21 +74,12 @@ post-configure:
.endfor
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= does not compile
-.endif
-
-LDFLAGS+=-L${LOCALBASE}/lib -L${OPENSSLLIB} ${PTHREAD_LIBS}
-PKG_CONFIG?=${LOCALBASE}/bin/pkg-config
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/libjingle/files/patch-talk__session__fileshare__fileshare.cc b/net-im/libjingle/files/patch-talk__session__fileshare__fileshare.cc
new file mode 100644
index 000000000000..ca08ee80fcdf
--- /dev/null
+++ b/net-im/libjingle/files/patch-talk__session__fileshare__fileshare.cc
@@ -0,0 +1,13 @@
+--- talk/session/fileshare/fileshare.cc.orig 2012-07-05 15:29:12.000000000 -0700
++++ talk/session/fileshare/fileshare.cc 2012-07-05 15:45:43.000000000 -0700
+@@ -670,8 +670,8 @@
+ && !query.empty()
+ && (sscanf(query.c_str(), "width=%u&height=%u",
+ &width, &height) == 2)) {
+- width = talk_base::_max<unsigned int>(1, talk_base::_min(width, kMaxPreviewSize));
+- height = talk_base::_max<unsigned int>(1, talk_base::_min(height, kMaxPreviewSize));
++ width = talk_base::_max<unsigned int>(1, talk_base::_min((size_t)width, kMaxPreviewSize));
++ height = talk_base::_max<unsigned int>(1, talk_base::_min((size_t)height, kMaxPreviewSize));
+ std::string pathname;
+ if (is_sender_) {
+ talk_base::Pathname local_path; \ No newline at end of file