aboutsummaryrefslogtreecommitdiff
path: root/net-im/libpurple/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-20 20:41:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-20 20:41:32 +0000
commit7f37df543a755e6964e1327b075fa4a58cea38f2 (patch)
treeae4064d4a90d450194744434e2d344992a5bfd66 /net-im/libpurple/Makefile
parent76809180883ceb29ca1c00f3bdf9076536259696 (diff)
downloadports-7f37df543a755e6964e1327b075fa4a58cea38f2.tar.gz
ports-7f37df543a755e6964e1327b075fa4a58cea38f2.zip
Notes
Diffstat (limited to 'net-im/libpurple/Makefile')
-rw-r--r--net-im/libpurple/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index f84fcd85d9f5..6b1186b1a711 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME?= libpurple
-PORTVERSION= 2.5.8
-PORTREVISION?= 2
+PORTVERSION= 2.6.1
+PORTREVISION?= 0
CATEGORIES?= net-im
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= pidgin
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_PROJECT}
+MASTER_SITE_SUBDIR= pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
MAINTAINER?= marcus@FreeBSD.org
@@ -52,6 +52,8 @@ OPTIONS= BONJOUR "Enable mDNS support" on \
GNUTLS "GNUTLS encryption support" off \
NSS "Mozilla NSS encryption support" on \
SASL "Cyrus SASL support (for jabberd)" off \
+ GSTREAMER "Use GStreamer for playing sounds" on \
+ VV "Enable video and voice support" on \
PERL "Perl scripting" off \
TCLTK "Tcl/Tk scripting" off \
SAMETIME "The Lotus Sametime chat protocol" off \
@@ -70,7 +72,6 @@ OPTIONS= BONJOUR "Enable mDNS support" on \
.if defined(WITH_GTKUI)
OPTIONS+= GTKSPELL "Spell checking support" on \
- GSTREAMER "Use GStreamer for playing sounds" on \
CAP "Enable Contact Availability Prediction plugin" on
.endif
@@ -98,12 +99,18 @@ CONFIGURE_ARGS+= --disable-gevolution
PLIST_SUB+= EVO="@comment not installed: "
.endif
-.if defined(WITH_GTKUI) && !defined(WITHOUT_GSTREAMER)
+.if !defined(WITHOUT_GSTREAMER)
USE_GSTREAMER+= core good
.else
CONFIGURE_ARGS+=--disable-gstreamer
.endif
+.if !defined(WITHOUT_VV)
+LIB_DEPENDS+= gstfarsight-0.10.0:${PORTSDIR}/net-im/farsight2
+.else
+CONFIGURE_ARGS+=--disable-vv
+.endif
+
.if defined(WITH_GTKUI) && !defined(WITHOUT_CAP)
LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+=--enable-cap