aboutsummaryrefslogtreecommitdiff
path: root/net-im/libyahoo2
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@FreeBSD.org>2004-02-14 07:18:35 +0000
committercvs2svn <cvs2svn@FreeBSD.org>2004-02-14 07:18:35 +0000
commit00535086d3a922b17e2beead589f92e6cd585ff8 (patch)
tree39749b1efaaad8c42f3be50320a00cac0799aacc /net-im/libyahoo2
parentb6deb36621300a80aab2d23031a1a259f9b0ce01 (diff)
This commit was manufactured by cvs2svn to create tag 'RELEASE_5_2_1'.release/5.2.1
Notes
Notes: svn path=/head/; revision=100899 svn path=/tags/RELEASE_5_2_1/; revision=100900; tag=release/5.2.1
Diffstat (limited to 'net-im/libyahoo2')
-rw-r--r--net-im/libyahoo2/Makefile28
-rw-r--r--net-im/libyahoo2/distinfo1
-rw-r--r--net-im/libyahoo2/files/patch-ltmain.sh33
-rw-r--r--net-im/libyahoo2/files/patch-sample_client.c36
-rw-r--r--net-im/libyahoo2/pkg-descr4
-rw-r--r--net-im/libyahoo2/pkg-plist11
6 files changed, 0 insertions, 113 deletions
diff --git a/net-im/libyahoo2/Makefile b/net-im/libyahoo2/Makefile
deleted file mode 100644
index 991840442acf..000000000000
--- a/net-im/libyahoo2/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: libyahoo2
-# Date created: Apr 6, 2003
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= libyahoo2
-PORTVERSION= 0.7.2
-CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A C library that handles the new Yahoo! Messenger protocol
-
-USE_BZIP2= yes
-USE_GNOME= glib20 gnomehack gnometarget
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-Wall -ansi -pedantic||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-g -Wall||g' ${WRKSRC}/src/Makefile.in
-
-.include <bsd.port.mk>
diff --git a/net-im/libyahoo2/distinfo b/net-im/libyahoo2/distinfo
deleted file mode 100644
index 9f3dd7e9220d..000000000000
--- a/net-im/libyahoo2/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (libyahoo2-0.7.2.tar.bz2) = 095fe136bd6a2b737a37e238124aaf91
diff --git a/net-im/libyahoo2/files/patch-ltmain.sh b/net-im/libyahoo2/files/patch-ltmain.sh
deleted file mode 100644
index 71d1d3044562..000000000000
--- a/net-im/libyahoo2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,33 +0,0 @@
---- ltmain.sh.orig Tue Jan 28 03:11:49 2003
-+++ ltmain.sh Tue May 13 06:46:55 2003
-@@ -1043,7 +1043,7 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
-@@ -2441,7 +2441,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4210,10 +4210,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net-im/libyahoo2/files/patch-sample_client.c b/net-im/libyahoo2/files/patch-sample_client.c
deleted file mode 100644
index 744c23d7224a..000000000000
--- a/net-im/libyahoo2/files/patch-sample_client.c
+++ /dev/null
@@ -1,36 +0,0 @@
---- src/sample_client.c.orig Sun Sep 28 10:40:03 2003
-+++ src/sample_client.c Tue Sep 30 21:35:55 2003
-@@ -52,7 +52,6 @@
- #include <yahoo2_callbacks.h>
- #include "yahoo_util.h"
-
--int fileno(FILE * stream);
-
-
- #define MAX_PREF_LEN 255
-@@ -177,7 +176,6 @@
-
- FILE *popen(const char *command, const char *type);
- int pclose(FILE *stream);
--int gethostname(char *name, size_t len);
-
- static char * get_local_addresses()
- {
-@@ -577,7 +575,7 @@
- if(tm) {
- char timestr[255];
-
-- strncpy(timestr, ctime(&tm), sizeof(timestr));
-+ strncpy(timestr, ctime((time_t *)&tm), sizeof(timestr));
- timestr[strlen(timestr) - 1] = '\0';
-
- print_message(("[Offline message at %s from %s]: %s",
-@@ -654,7 +652,7 @@
- }
-
- void ext_yahoo_got_webcam_image(int id, const char *who,
-- unsigned char *image, unsigned int image_size, unsigned int real_size,
-+ const unsigned char *image, unsigned int image_size, unsigned int real_size,
- unsigned int timestamp)
- {
- static unsigned char *cur_image = NULL;
diff --git a/net-im/libyahoo2/pkg-descr b/net-im/libyahoo2/pkg-descr
deleted file mode 100644
index 95a39a5b6bf5..000000000000
--- a/net-im/libyahoo2/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-libyahoo2 is a C library interface to the new Yahoo! Messenger protocol.
-It supports almost all current features of the protocol.
-
-WWW: http://libyahoo2.sourceforge.net/
diff --git a/net-im/libyahoo2/pkg-plist b/net-im/libyahoo2/pkg-plist
deleted file mode 100644
index a62a3ef0c0d1..000000000000
--- a/net-im/libyahoo2/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-@comment $FreeBSD$
-include/libyahoo2/yahoo2.h
-include/libyahoo2/yahoo2_callbacks.h
-include/libyahoo2/yahoo2_types.h
-include/libyahoo2/yahoo_httplib.h
-include/libyahoo2/yahoo_list.h
-lib/libyahoo2.a
-lib/libyahoo2.so
-lib/libyahoo2.so.5
-libdata/pkgconfig/libyahoo2.pc
-@dirrm include/libyahoo2