aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-11-27 12:27:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-11-27 12:27:26 +0000
commit584a4de6e2fd426c24bb3c88f0532d807bd04f5a (patch)
tree066a8d631a0cfea9fc3bc2495a23db30eae57281 /net-im/licq
parent8d08ec5a5635f1fefaa2cf8e8739909be8df21c7 (diff)
downloadports-584a4de6e2fd426c24bb3c88f0532d807bd04f5a.tar.gz
ports-584a4de6e2fd426c24bb3c88f0532d807bd04f5a.zip
Notes
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/Makefile21
-rw-r--r--net-im/licq/Makefile.inc16
-rw-r--r--net-im/licq/distinfo6
-rw-r--r--net-im/licq/files/patch-CMakeLists.txt12
-rw-r--r--net-im/licq/pkg-descr2
-rw-r--r--net-im/licq/pkg-plist115
6 files changed, 99 insertions, 73 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index c1c706843067..a5d1d62401a8 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -18,16 +18,18 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
+LICENSE= GPLv2
+
USE_ICONV= yes
+USE_CMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
# workaround for installed autoconf/automake
-CONFIGURE_ARGS+=--program-transform-name=s,y,y,
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv -Wl,--export-dynamic
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -Wl,--export-dynamic
.if defined(WITH_SOCKS)
SOCKS_SUFFIX= -socks
@@ -47,24 +49,16 @@ CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
.endif
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
+CMAKE_ARGS+= -DENABLE_NLS:BOOL=OFF
PLIST_SUB+= NLS="@comment "
.else
+USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
pre-configure:
- ${REINPLACE_CMD} -e 's=/usr/share/licq=${PREFIX}/share/licq=' \
- ${WRKSRC}/src/licq.conf.h
- @${ECHO_MSG} Ignoring existing libgnugetopt
${REINPLACE_CMD} -e 's=!/bin/bash=!${LOCALBASE}/bin/bash=' \
${WRKSRC}/bin/sidclean.sh
- ${REINPLACE_CMD} -e 's=getopt.h==' \
- -e 's=FLAGS -D_THREAD_SAFE=FLAGS ${PTHREAD_CFLAGS}=' \
- -e 's=FLAGS -pthread=FLAGS ${PTHREAD_CFLAGS}=' \
- -e "s=-lc_r=${PTHREAD_LIBS}=" \
- -e 's=-lc *$$LIBS=$$LIBS=' \
- ${WRKSRC}/configure
post-install:
@${MKDIR} ${PREFIX}/lib/licq
@@ -72,6 +66,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/sidclean.sh ${PREFIX}/bin/sidclean.bash
.include <bsd.port.pre.mk>
+
.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/net-im/licq/Makefile.inc b/net-im/licq/Makefile.inc
index 7fd6387973ee..3d07daeb8d1c 100644
--- a/net-im/licq/Makefile.inc
+++ b/net-im/licq/Makefile.inc
@@ -2,21 +2,17 @@
# $FreeBSD$
PKGNAMEPREFIX= licq-
-LICQ_VER= 1.3.9
-QT_LICQ_VER= 1.3.9
-OSD_LICQ_VER= 1.3.9
-CONSOLE_LICQ_VER= 1.3.9
+LICQ_VER= 1.5.0
+QT_LICQ_VER= 1.5.0
+OSD_LICQ_VER= 1.5.0
+CONSOLE_LICQ_VER= 1.5.0
.if ${PORTNAME} != "base"
+BUILD_DEPENDS+= licq:${PORTSDIR}/${LICQ_PORT}
RUN_DEPENDS+= licq:${PORTSDIR}/${LICQ_PORT}
+WRKSRC?= ${WRKDIR}/${DISTNAME}/plugins/${PORTNAME}
.endif
MASTER_SITES= SF/licq/licq/${LICQ_VER}
DISTNAME= ${PKGNAMEPREFIX}${LICQ_VER}
DISTFILES= ${DISTNAME}.tar.bz2
-GNU_CONFIGURE= yes
DISTINFO_FILE?= ${PORTSDIR}/${LICQ_PORT}/distinfo
-USE_GMAKE= yes
USE_BZIP2= yes
-WRKSRC?= ${WRKDIR}/${DISTNAME}/plugins/${PORTNAME}
-PLIST_SUB+= LICQ_DEVEL="@comment "
-CXXFLAGS+= -Wno-deprecated
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
diff --git a/net-im/licq/distinfo b/net-im/licq/distinfo
index 06a813ae58c5..bc9c47279c54 100644
--- a/net-im/licq/distinfo
+++ b/net-im/licq/distinfo
@@ -1,3 +1,3 @@
-MD5 (licq-1.3.9.tar.bz2) = 5285efd538fc5540cc85bc8979b8efae
-SHA256 (licq-1.3.9.tar.bz2) = 67c300a3b7045a1d6f182f4824a9c6815f9b71db1816885fc83bf9937fffd056
-SIZE (licq-1.3.9.tar.bz2) = 4507409
+MD5 (licq-1.5.0.tar.bz2) = 49f4d325c06e45cfeeee34c870bade47
+SHA256 (licq-1.5.0.tar.bz2) = 3dd1519040971c828015e70041e85b69b64611e111ddcbeb41464ebaa62d5136
+SIZE (licq-1.5.0.tar.bz2) = 2207403
diff --git a/net-im/licq/files/patch-CMakeLists.txt b/net-im/licq/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..494bbd2ecf6d
--- /dev/null
+++ b/net-im/licq/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2010-09-19 16:53:59.000000000 +0200
++++ CMakeLists.txt 2010-10-15 10:59:24.000000000 +0200
+@@ -170,7 +170,9 @@
+
+ add_subdirectory(cmake)
+ add_subdirectory(include)
++if (ENABLE_NLS)
+ add_subdirectory(po)
++endif (ENABLE_NLS)
+ add_subdirectory(share)
+ add_subdirectory(src)
+
diff --git a/net-im/licq/pkg-descr b/net-im/licq/pkg-descr
index d0fcb6465b59..f38fe8a606cc 100644
--- a/net-im/licq/pkg-descr
+++ b/net-im/licq/pkg-descr
@@ -2,4 +2,6 @@ This is an unofficial ICQ clone, written in C++.
It is in no way endorsed by Mirabilis, and now is the most full-featured
ICQ-compatible program with the exception of Java ICQ.
+LICENSE: GPL2 or later with execption to link with OpenSSL
+
WWW: http://www.licq.org/
diff --git a/net-im/licq/pkg-plist b/net-im/licq/pkg-plist
index 7ed57094eeab..6d8444e6068c 100644
--- a/net-im/licq/pkg-plist
+++ b/net-im/licq/pkg-plist
@@ -1,47 +1,63 @@
bin/licq
bin/sidclean.bash
-bin/viewurl-firefox.sh
-bin/viewurl-lynx.sh
-bin/viewurl-mozilla.sh
-bin/viewurl-ncftp.sh
-bin/viewurl-netscape.sh
-bin/viewurl-opera.sh
-bin/viewurl-seamonkey.sh
-bin/viewurl-w3m.sh
-include/licq/licq_backgroundcodes.h
-include/licq/licq_buffer.h
-include/licq/licq_chat.h
-include/licq/licq_color.h
-include/licq/licq_constants.h
-include/licq/licq_countrycodes.h
-include/licq/licq_events.h
-include/licq/licq_file.h
-include/licq/licq_filetransfer.h
-include/licq/licq_history.h
-include/licq/licq_homepagecodes.h
-include/licq/licq_icq.h
-include/licq/licq_icqd.h
-include/licq/licq_interestcodes.h
-include/licq/licq_languagecodes.h
-include/licq/licq_log.h
-include/licq/licq_message.h
-include/licq/licq_mutex.h
-include/licq/licq_occupationcodes.h
-include/licq/licq_onevent.h
-include/licq/licq_organizationcodes.h
-include/licq/licq_packets.h
-include/licq/licq_plugin.h
-include/licq/licq_plugind.h
-include/licq/licq_protoplugin.h
-include/licq/licq_protoplugind.h
-include/licq/licq_providers.h
-include/licq/licq_proxy.h
-include/licq/licq_sar.h
-include/licq/licq_sighandler.h
-include/licq/licq_socket.h
-include/licq/licq_translate.h
-include/licq/licq_user.h
-include/licq/licq_utility.h
+include/licq/buffer.h
+include/licq/byteorder.h
+include/licq/color.h
+include/licq/contactlist/group.h
+include/licq/contactlist/owner.h
+include/licq/contactlist/user.h
+include/licq/contactlist/usermanager.h
+include/licq/conversation.h
+include/licq/daemon.h
+include/licq/event.h
+include/licq/exceptions/exception.h
+include/licq/gpghelper.h
+include/licq/icq.h
+include/licq/icqchat.h
+include/licq/icqcodes.h
+include/licq/icqdefines.h
+include/licq/icqfiletransfer.h
+include/licq/inifile.h
+include/licq/licqversion.h
+include/licq/logging/log.h
+include/licq/logging/logservice.h
+include/licq/logging/logsink.h
+include/licq/logging/logutils.h
+include/licq/logging/pluginlogsink.h
+include/licq/macro.h
+include/licq/md5.h
+include/licq/oneventmanager.h
+include/licq/packet.h
+include/licq/pipe.h
+include/licq/plugin.h
+include/licq/pluginbase.h
+include/licq/pluginmanager.h
+include/licq/pluginsignal.h
+include/licq/protocolbase.h
+include/licq/protocolmanager.h
+include/licq/protocolsignal.h
+include/licq/proxy.h
+include/licq/sarmanager.h
+include/licq/socket.h
+include/licq/socketmanager.h
+include/licq/statistics.h
+include/licq/thread/condition.h
+include/licq/thread/lockable.h
+include/licq/thread/mutex.h
+include/licq/thread/mutexlocker.h
+include/licq/thread/readwritemutex.h
+include/licq/thread/threadspecificdata.h
+include/licq/translator.h
+include/licq/userevents.h
+include/licq/userid.h
+include/licq/utility.h
+include/licq/version.h
+share/licq/cmake/FindLicq.cmake
+share/licq/cmake/LicqCommonCompilerFlags.cmake
+share/licq/cmake/LicqConfig.cmake
+share/licq/cmake/LicqPaths.cmake
+share/licq/cmake/Modules/FindIconv.cmake
+share/licq/cmake/cmake_uninstall.cmake.in
share/licq/sounds/Monty-Python.wav
share/licq/sounds/fun/Auth.wav
share/licq/sounds/fun/Chat.wav
@@ -101,7 +117,6 @@ share/licq/utilities/gftp.utility
share/licq/utilities/hostname.utility
share/licq/utilities/kmail.utility
share/licq/utilities/mutt.utility
-share/licq/utilities/netscape.utility
share/licq/utilities/nmap.utility
share/licq/utilities/pine.utility
share/licq/utilities/ping.utility
@@ -114,12 +129,18 @@ share/licq/utilities/xtraceroute.utility
%%NLS%%share/locale/be/LC_MESSAGES/licq.mo
%%NLS%%share/locale/de/LC_MESSAGES/licq.mo
%%NLS%%share/locale/es/LC_MESSAGES/licq.mo
-@dirrm include/licq
@exec mkdir -p %D/lib/licq
@dirrm lib/licq
-@dirrm share/licq/sounds/fun
+@dirrm share/licq/utilities
+@dirrm share/licq/translations
@dirrm share/licq/sounds/icq
+@dirrm share/licq/sounds/fun
@dirrm share/licq/sounds
-@dirrm share/licq/translations
-@dirrm share/licq/utilities
+@dirrm share/licq/cmake/Modules
+@dirrm share/licq/cmake
@dirrm share/licq
+@dirrm include/licq/thread
+@dirrm include/licq/logging
+@dirrm include/licq/exceptions
+@dirrm include/licq/contactlist
+@dirrm include/licq