aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-12-20 15:31:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-12-20 15:31:34 +0000
commit93191a3d01a409048a7e2c8940c0d9d6f4f0879b (patch)
tree22474f70486d5bba8224d8e6ca89a8fd81d18314 /net-im/licq
parent42cc30b381a22a262247c5bcfd2508fb113e7eff (diff)
downloadports-93191a3d01a409048a7e2c8940c0d9d6f4f0879b.tar.gz
ports-93191a3d01a409048a7e2c8940c0d9d6f4f0879b.zip
Notes
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/Makefile8
-rw-r--r--net-im/licq/Makefile.inc8
-rw-r--r--net-im/licq/distinfo6
-rw-r--r--net-im/licq/files/patch-translate.cpp56
4 files changed, 69 insertions, 9 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index e694a4d847be..37baf5bc696e 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -19,13 +19,17 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
USE_REINPLACE= yes
+USE_ICONV= yes
+#USE_GCC= 3.3+
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
# workaround for installed autoconf/automake
CONFIGURE_ARGS+=--program-transform-name=s,y,y,
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-LDFLAGS+= ${PTHREAD_LIBS}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
.if defined(WITH_SOCKS)
SOCKS_SUFFIX= -socks
diff --git a/net-im/licq/Makefile.inc b/net-im/licq/Makefile.inc
index 944a7756c91d..7a68751d47c7 100644
--- a/net-im/licq/Makefile.inc
+++ b/net-im/licq/Makefile.inc
@@ -2,11 +2,11 @@
# $FreeBSD$
PKGNAMEPREFIX= licq-
-LICQ_VER= 1.3.0
-QT_LICQ_VER= 1.3.0
-OSD_LICQ_VER= 1.3.0
+LICQ_VER= 1.3.2
+QT_LICQ_VER= 1.3.2
+OSD_LICQ_VER= 1.3.2
RMS_LICQ_VER= 0.33
-CONSOLE_LICQ_VER= 1.3.0
+CONSOLE_LICQ_VER= 1.3.2
JONS_GTK_LICQ_VER= 0.20.2
.if ${PORTNAME} != "base"
RUN_DEPENDS+= licq:${PORTSDIR}/${LICQ_PORT}
diff --git a/net-im/licq/distinfo b/net-im/licq/distinfo
index 2a8097c69ad0..e21e8e9f2e3d 100644
--- a/net-im/licq/distinfo
+++ b/net-im/licq/distinfo
@@ -1,3 +1,3 @@
-MD5 (licq-1.3.0.tar.bz2) = c1b05d1078b9826273191c05d0d1a969
-SHA256 (licq-1.3.0.tar.bz2) = f7d6574f5ee6fea5234da269ab09756c26f05d725580f72e482d53d40e1bd47c
-SIZE (licq-1.3.0.tar.bz2) = 4284325
+MD5 (licq-1.3.2.tar.bz2) = 0471bb8fed91eefb23dfe153c9a4a806
+SHA256 (licq-1.3.2.tar.bz2) = 3c6ec77d42973c93a9d1926a3aa444ff0388263f38a19c9b51e1337cde60f8bc
+SIZE (licq-1.3.2.tar.bz2) = 3980117
diff --git a/net-im/licq/files/patch-translate.cpp b/net-im/licq/files/patch-translate.cpp
new file mode 100644
index 000000000000..836fce3920b5
--- /dev/null
+++ b/net-im/licq/files/patch-translate.cpp
@@ -0,0 +1,56 @@
+--- src/translate.cpp.orig Thu Oct 13 17:09:23 2005
++++ src/translate.cpp Sun Dec 11 16:46:24 2005
+@@ -223,7 +223,8 @@
+ char *szNewStr = new char[nLen + 1];
+ size_t nInSize, nOutSize;
+
+- char *szIn = _sz, *szOut = szNewStr;
++ const char *szIn = _sz;
++ char *szOut = szNewStr;
+ iconv_t tr;
+
+ nInSize = nLen;
+@@ -268,7 +269,8 @@
+ char *szNewStr = new char[nLen + 1];
+ size_t nInSize, nOutSize;
+
+- char *szIn = _sz, *szOut = szNewStr;
++ const char *szIn = _sz;
++ char *szOut = szNewStr;
+ iconv_t tr;
+
+ nInSize = nLen;
+@@ -312,7 +314,8 @@
+ char *szNewStr = new char[nLen * 2];
+ size_t nInSize, nOutSize;
+
+- char *szIn = _sz, *szOut = szNewStr;
++ const char *szIn = _sz;
++ char *szOut = szNewStr;
+ iconv_t tr;
+
+ nInSize = nLen;
+@@ -339,11 +342,21 @@
+ unsigned short nLen = strlen(_sz) * 3;
+ char *szNewStr = new char[nLen + 1];
+ size_t nInSize, nOutSize;
+- char *szOut = szNewStr, *szIn = _sz;
++ const char *szIn = _sz;
++ char *szOut = szNewStr;
+ iconv_t tr;
+
+ nInSize = strlen(szIn);
+ nOutSize = nLen;
++ //--- deleting ' ' from _szEncoding ---
++ char *_szEnc_tmp = _szEncoding, *_szEnc_tmp2 = _szEncoding;
++ int _szflag = 0;
++ while (*_szEnc_tmp)
++ {
++ if (*_szEnc_tmp == ' ') {*_szEnc_tmp++; _szflag++;}
++ *_szEnc_tmp2++ = *_szEnc_tmp++;
++ }
++ while(_szflag--) --(*_szEnc_tmp2) = '\0';
+
+ tr = iconv_open("UCS-2BE", _szEncoding);
+ size_t ret = iconv(tr, &szIn, &nInSize, &szOut, &nOutSize);
+