aboutsummaryrefslogtreecommitdiff
path: root/net-im/mcabber
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-13 00:53:27 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-13 00:53:27 +0000
commit5630608ef950fd89a09d1c66c280853a52a092ba (patch)
treef986b172e3435241ecdf3b7abd35cfb0a94cbdd1 /net-im/mcabber
parent4db5c3f7b5b7b2e84e5f817c4cc5ff5ccfaeeb7b (diff)
downloadports-5630608ef950fd89a09d1c66c280853a52a092ba.tar.gz
ports-5630608ef950fd89a09d1c66c280853a52a092ba.zip
Notes
Diffstat (limited to 'net-im/mcabber')
-rw-r--r--net-im/mcabber/Makefile23
-rw-r--r--net-im/mcabber/distinfo6
-rw-r--r--net-im/mcabber/files/patch-libjabber__jconn.c4
-rw-r--r--net-im/mcabber/files/patch-src__hbuf.c8
-rw-r--r--net-im/mcabber/pkg-plist93
5 files changed, 112 insertions, 22 deletions
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 10dd1a10d511..b030ddcd0b7d 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= mcabber
-PORTVERSION= 0.8.3
+PORTVERSION= 0.9.0
CATEGORIES= net-im
MASTER_SITES= http://www.lilotux.net/~mikael/mcabber/files/ CSME
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Small Jabber console client
-LIB_DEPENDS= ncursesw.5:${PORTSDIR}/devel/ncurses
+LIB_DEPENDS= ncursesw.5:${PORTSDIR}/devel/ncurses \
+ gpgme.17:${PORTSDIR}/security/gpgme
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man --with-ssl
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --with-ssl
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_OPENSSL= yes
USE_ICONV= yes
USE_GETTEXT= yes
USE_GNOME= glib20
-USE_GETOPT_LONG= yes
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS= ${CFLAGS}
-LDFLAGS+= -lcrypto -L${LOCALBASE}/lib
+USE_GETOPT_LONG=yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
MAN1= mcabber.1
@@ -37,13 +37,10 @@ BROKEN= Unicoded ncurses require 5.3
.endif
post-patch:
- @${REINPLACE_CMD} -e 's#$$"$${datadir}"#"$${datadir}"#' \
- -e 's/waddnwstr/mvwaddnwstr/g' -e 's!ncursesw/!ncurses/!g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's/NCURSESW/NCURSES/' ${WRKSRC}/src/screen.h ${WRKSRC}/src/utf8.h
- @${REINPLACE_CMD} -e 's!ncursesw/!ncurses/!g' ${WRKSRC}/src/screen.h
+ @${REINPLACE_CMD} -e 's#$$"$${datadir}"#"$${datadir}"#' ${WRKSRC}/configure
post-install:
- @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL} -d ${EXAMPLESDIR}/
@${CP} -R ${WRKSRC}/contrib ${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/mcabberrc.example ${EXAMPLESDIR}/mcabberrc
diff --git a/net-im/mcabber/distinfo b/net-im/mcabber/distinfo
index 5d6c39fe938c..d23dbe86afce 100644
--- a/net-im/mcabber/distinfo
+++ b/net-im/mcabber/distinfo
@@ -1,3 +1,3 @@
-MD5 (mcabber-0.8.3.tar.bz2) = 714f175fa24da7d0af0ea8097d7b32e1
-SHA256 (mcabber-0.8.3.tar.bz2) = 2327907ddfd970752d10f258f6acc4587bd5dfc62925d7348f45b7e056706a81
-SIZE (mcabber-0.8.3.tar.bz2) = 374370
+MD5 (mcabber-0.9.0.tar.bz2) = cdf0ed6357c8b27510bd163a5fc64660
+SHA256 (mcabber-0.9.0.tar.bz2) = 836f774af8d039fd0b5cb5851fa2a672e7b320a0c4397beec77567ee67818376
+SIZE (mcabber-0.9.0.tar.bz2) = 414052
diff --git a/net-im/mcabber/files/patch-libjabber__jconn.c b/net-im/mcabber/files/patch-libjabber__jconn.c
index 7272af4e5111..e9c5a3c9529d 100644
--- a/net-im/mcabber/files/patch-libjabber__jconn.c
+++ b/net-im/mcabber/files/patch-libjabber__jconn.c
@@ -1,5 +1,5 @@
---- ./libjabber/jconn.c.orig Sun Aug 13 23:01:59 2006
-+++ ./libjabber/jconn.c Mon Aug 14 10:15:47 2006
+--- ./libjabber/jconn.c.orig Sat Dec 16 21:05:39 2006
++++ ./libjabber/jconn.c Sat Jan 13 03:02:55 2007
@@ -164,6 +164,9 @@
}
change_socket_to_blocking(j->fd);
diff --git a/net-im/mcabber/files/patch-src__hbuf.c b/net-im/mcabber/files/patch-src__hbuf.c
index 758f0cadd613..18d7ec048efb 100644
--- a/net-im/mcabber/files/patch-src__hbuf.c
+++ b/net-im/mcabber/files/patch-src__hbuf.c
@@ -1,6 +1,6 @@
---- ./src/hbuf.c.orig Sun Aug 13 23:01:59 2006
-+++ ./src/hbuf.c Mon Aug 14 10:15:38 2006
-@@ -252,6 +252,7 @@
+--- ./src/hbuf.c.orig Sat Dec 16 21:05:39 2006
++++ ./src/hbuf.c Sat Jan 13 03:02:55 2007
+@@ -250,6 +250,7 @@
hbuf_block *blk;
guchar last_persist_prefixflags = 0;
GList *last_persist; // last persistent flags
@@ -8,7 +8,7 @@
hbb_line **array, **array_elt;
// To be able to correctly highlight multi-line messages,
-@@ -272,7 +273,6 @@
+@@ -270,7 +271,6 @@
for (i = 0 ; i < n ; i++) {
if (hbuf) {
diff --git a/net-im/mcabber/pkg-plist b/net-im/mcabber/pkg-plist
index 1b4b64ed06f6..7969de4f62fd 100644
--- a/net-im/mcabber/pkg-plist
+++ b/net-im/mcabber/pkg-plist
@@ -6,6 +6,35 @@ bin/mcabber
%%DATADIR%%/contrib/themes/light.txt
%%DATADIR%%/contrib/themes/light2.txt
%%DATADIR%%/contrib/themes/oliver.txt
+%%DATADIR%%/help/de/hlp.txt
+%%DATADIR%%/help/de/hlp_add.txt
+%%DATADIR%%/help/de/hlp_alias.txt
+%%DATADIR%%/help/de/hlp_authorization.txt
+%%DATADIR%%/help/de/hlp_bind.txt
+%%DATADIR%%/help/de/hlp_buffer.txt
+%%DATADIR%%/help/de/hlp_clear.txt
+%%DATADIR%%/help/de/hlp_connect.txt
+%%DATADIR%%/help/de/hlp_del.txt
+%%DATADIR%%/help/de/hlp_disconnect.txt
+%%DATADIR%%/help/de/hlp_event.txt
+%%DATADIR%%/help/de/hlp_group.txt
+%%DATADIR%%/help/de/hlp_help.txt
+%%DATADIR%%/help/de/hlp_info.txt
+%%DATADIR%%/help/de/hlp_move.txt
+%%DATADIR%%/help/de/hlp_msay.txt
+%%DATADIR%%/help/de/hlp_pgp.txt
+%%DATADIR%%/help/de/hlp_quit.txt
+%%DATADIR%%/help/de/hlp_rawxml.txt
+%%DATADIR%%/help/de/hlp_rename.txt
+%%DATADIR%%/help/de/hlp_request.txt
+%%DATADIR%%/help/de/hlp_room.txt
+%%DATADIR%%/help/de/hlp_roster.txt
+%%DATADIR%%/help/de/hlp_say.txt
+%%DATADIR%%/help/de/hlp_say_to.txt
+%%DATADIR%%/help/de/hlp_set.txt
+%%DATADIR%%/help/de/hlp_status.txt
+%%DATADIR%%/help/de/hlp_status_to.txt
+%%DATADIR%%/help/de/hlp_version.txt
%%DATADIR%%/help/en/hlp.txt
%%DATADIR%%/help/en/hlp_add.txt
%%DATADIR%%/help/en/hlp_alias.txt
@@ -22,6 +51,7 @@ bin/mcabber
%%DATADIR%%/help/en/hlp_info.txt
%%DATADIR%%/help/en/hlp_move.txt
%%DATADIR%%/help/en/hlp_msay.txt
+%%DATADIR%%/help/en/hlp_pgp.txt
%%DATADIR%%/help/en/hlp_quit.txt
%%DATADIR%%/help/en/hlp_rawxml.txt
%%DATADIR%%/help/en/hlp_rename.txt
@@ -50,6 +80,7 @@ bin/mcabber
%%DATADIR%%/help/fr/hlp_info.txt
%%DATADIR%%/help/fr/hlp_move.txt
%%DATADIR%%/help/fr/hlp_msay.txt
+%%DATADIR%%/help/fr/hlp_pgp.txt
%%DATADIR%%/help/fr/hlp_quit.txt
%%DATADIR%%/help/fr/hlp_rawxml.txt
%%DATADIR%%/help/fr/hlp_rename.txt
@@ -62,6 +93,35 @@ bin/mcabber
%%DATADIR%%/help/fr/hlp_status.txt
%%DATADIR%%/help/fr/hlp_status_to.txt
%%DATADIR%%/help/fr/hlp_version.txt
+%%DATADIR%%/help/nl/hlp.txt
+%%DATADIR%%/help/nl/hlp_add.txt
+%%DATADIR%%/help/nl/hlp_alias.txt
+%%DATADIR%%/help/nl/hlp_authorization.txt
+%%DATADIR%%/help/nl/hlp_bind.txt
+%%DATADIR%%/help/nl/hlp_buffer.txt
+%%DATADIR%%/help/nl/hlp_clear.txt
+%%DATADIR%%/help/nl/hlp_connect.txt
+%%DATADIR%%/help/nl/hlp_del.txt
+%%DATADIR%%/help/nl/hlp_disconnect.txt
+%%DATADIR%%/help/nl/hlp_event.txt
+%%DATADIR%%/help/nl/hlp_group.txt
+%%DATADIR%%/help/nl/hlp_help.txt
+%%DATADIR%%/help/nl/hlp_info.txt
+%%DATADIR%%/help/nl/hlp_move.txt
+%%DATADIR%%/help/nl/hlp_msay.txt
+%%DATADIR%%/help/nl/hlp_pgp.txt
+%%DATADIR%%/help/nl/hlp_quit.txt
+%%DATADIR%%/help/nl/hlp_rawxml.txt
+%%DATADIR%%/help/nl/hlp_rename.txt
+%%DATADIR%%/help/nl/hlp_request.txt
+%%DATADIR%%/help/nl/hlp_room.txt
+%%DATADIR%%/help/nl/hlp_roster.txt
+%%DATADIR%%/help/nl/hlp_say.txt
+%%DATADIR%%/help/nl/hlp_say_to.txt
+%%DATADIR%%/help/nl/hlp_set.txt
+%%DATADIR%%/help/nl/hlp_status.txt
+%%DATADIR%%/help/nl/hlp_status_to.txt
+%%DATADIR%%/help/nl/hlp_version.txt
%%DATADIR%%/help/pl/hlp.txt
%%DATADIR%%/help/pl/hlp_add.txt
%%DATADIR%%/help/pl/hlp_alias.txt
@@ -78,6 +138,7 @@ bin/mcabber
%%DATADIR%%/help/pl/hlp_info.txt
%%DATADIR%%/help/pl/hlp_move.txt
%%DATADIR%%/help/pl/hlp_msay.txt
+%%DATADIR%%/help/pl/hlp_pgp.txt
%%DATADIR%%/help/pl/hlp_quit.txt
%%DATADIR%%/help/pl/hlp_rawxml.txt
%%DATADIR%%/help/pl/hlp_rename.txt
@@ -90,11 +151,43 @@ bin/mcabber
%%DATADIR%%/help/pl/hlp_status.txt
%%DATADIR%%/help/pl/hlp_status_to.txt
%%DATADIR%%/help/pl/hlp_version.txt
+%%DATADIR%%/help/uk/hlp.txt
+%%DATADIR%%/help/uk/hlp_add.txt
+%%DATADIR%%/help/uk/hlp_alias.txt
+%%DATADIR%%/help/uk/hlp_authorization.txt
+%%DATADIR%%/help/uk/hlp_bind.txt
+%%DATADIR%%/help/uk/hlp_buffer.txt
+%%DATADIR%%/help/uk/hlp_clear.txt
+%%DATADIR%%/help/uk/hlp_connect.txt
+%%DATADIR%%/help/uk/hlp_del.txt
+%%DATADIR%%/help/uk/hlp_disconnect.txt
+%%DATADIR%%/help/uk/hlp_event.txt
+%%DATADIR%%/help/uk/hlp_group.txt
+%%DATADIR%%/help/uk/hlp_help.txt
+%%DATADIR%%/help/uk/hlp_info.txt
+%%DATADIR%%/help/uk/hlp_move.txt
+%%DATADIR%%/help/uk/hlp_msay.txt
+%%DATADIR%%/help/uk/hlp_pgp.txt
+%%DATADIR%%/help/uk/hlp_quit.txt
+%%DATADIR%%/help/uk/hlp_rawxml.txt
+%%DATADIR%%/help/uk/hlp_rename.txt
+%%DATADIR%%/help/uk/hlp_request.txt
+%%DATADIR%%/help/uk/hlp_room.txt
+%%DATADIR%%/help/uk/hlp_roster.txt
+%%DATADIR%%/help/uk/hlp_say.txt
+%%DATADIR%%/help/uk/hlp_say_to.txt
+%%DATADIR%%/help/uk/hlp_set.txt
+%%DATADIR%%/help/uk/hlp_status.txt
+%%DATADIR%%/help/uk/hlp_status_to.txt
+%%DATADIR%%/help/uk/hlp_version.txt
@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%/contrib/themes
@dirrm %%DATADIR%%/contrib
+@dirrm %%DATADIR%%/help/de
@dirrm %%DATADIR%%/help/en
@dirrm %%DATADIR%%/help/fr
+@dirrm %%DATADIR%%/help/nl
@dirrm %%DATADIR%%/help/pl
+@dirrm %%DATADIR%%/help/uk
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%