aboutsummaryrefslogtreecommitdiff
path: root/net-im/mercury/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-06-20 19:59:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-06-20 19:59:52 +0000
commit53311905bbf92d5652d8fdf449a31e9d8e0df254 (patch)
treec8c4a1b2406ca224f37d4b00511c1cfbecf0ac46 /net-im/mercury/Makefile
parent3114180a170c990a352a4f3c9b25ba21b48e5aa5 (diff)
downloadports-53311905bbf92d5652d8fdf449a31e9d8e0df254.tar.gz
ports-53311905bbf92d5652d8fdf449a31e9d8e0df254.zip
Notes
Diffstat (limited to 'net-im/mercury/Makefile')
-rw-r--r--net-im/mercury/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/net-im/mercury/Makefile b/net-im/mercury/Makefile
index 6151f9ed39dd..46d8723a15fd 100644
--- a/net-im/mercury/Makefile
+++ b/net-im/mercury/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= mercury
-DISTVERSION= 1709_RC10
+DISTVERSION= 1709_RC11f
CATEGORIES= net java
-MASTER_SITES= http://rebel.chillhoek.nl/ \
- http://www.mcroney.com/nss-folder/uploadfileshere/ \
+MASTER_SITES= http://70.25.151.230/ \
http://download.mercury.to/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry/${PORTNAME}
@@ -38,6 +37,15 @@ INSTDIR= ${PREFIX}/${LINSTDIR}
PLIST_SUB= INSTDIR=${LINSTDIR}
SUB_DIRS= lib resources
+.if defined(WITH_VIDEO) # Experimental
+VIDJAR= VidConf-libs.jar
+EXTRACT_ONLY+= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${VIDJAR}
+PLIST_SUB+= VID="" VIDJAR="${VIDJAR}"
+.else
+PLIST_SUB+= VID="@comment " VIDJAR=""
+.endif
+
do-install:
${MKDIR} ${INSTDIR}
${INSTALL_SCRIPT} ${WRKDIR}/${SUB_FILES} ${INSTDIR}
@@ -46,5 +54,8 @@ do-install:
cd ${WRKDIR} && ${FIND} ${sd} -type d -exec ${MKDIR} ${INSTDIR}/{} \;
cd ${WRKDIR} && ${FIND} ${sd} -type f -exec ${INSTALL_DATA} {} ${INSTDIR}/{} \;
.endfor
+.if defined(WITH_VIDEO)
+ ${INSTALL_DATA} ${_DISTDIR}/${VIDJAR} ${INSTDIR}/lib
+.endif
.include <bsd.port.mk>