aboutsummaryrefslogtreecommitdiff
path: root/net-im/mu-conference
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-16 14:45:23 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-16 14:45:23 +0000
commit638d17ab34e7013a99314142e8d4a53e80f7fcf2 (patch)
tree219946abdeee5ad7eac8045f5b73bcb5e7c892fb /net-im/mu-conference
parent15422dc867641963ce6b7bda3b91829e036ba4a1 (diff)
downloadports-638d17ab34e7013a99314142e8d4a53e80f7fcf2.tar.gz
ports-638d17ab34e7013a99314142e8d4a53e80f7fcf2.zip
Notes
Diffstat (limited to 'net-im/mu-conference')
-rw-r--r--net-im/mu-conference/Makefile4
-rw-r--r--net-im/mu-conference/files/mu-conference.sh.in47
2 files changed, 50 insertions, 1 deletions
diff --git a/net-im/mu-conference/Makefile b/net-im/mu-conference/Makefile
index 8220339105f0..5ec5dc30bd67 100644
--- a/net-im/mu-conference/Makefile
+++ b/net-im/mu-conference/Makefile
@@ -6,7 +6,7 @@
PORTNAME= mu-conference
PORTVERSION= 0.6.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_GENTOO} \
http://jabber.terrapin.com/JCR/:jcr
@@ -17,6 +17,8 @@ MAINTAINER= dsh@vlink.ru
COMMENT= Multi-User Conferencing component for Jabber
USE_GNOME= glib20
+USE_RC_SUBR= ${PORTNAME}.sh
+
WRKSRC= ${WRKDIR}/jcr-${JCR_VER}
JCR_VER?= 0.2.4
diff --git a/net-im/mu-conference/files/mu-conference.sh.in b/net-im/mu-conference/files/mu-conference.sh.in
new file mode 100644
index 000000000000..3c5406bd1bc5
--- /dev/null
+++ b/net-im/mu-conference/files/mu-conference.sh.in
@@ -0,0 +1,47 @@
+#!/bin/sh
+
+# Start or stop jabber's mu-conference
+# $FreeBSD$
+
+# PROVIDE: mu_conference
+# REQUIRE: DAEMON jabberd
+# KEYWORD: FreeBSD shutdown
+#
+# Define these mu_conference_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/mu_conference
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+# mu_conference_config : path
+# Path to the configuration file ("%%PREFIX%%/etc/muc.xml", the default).
+#
+# mu_conference_enable : bool
+# Enable ("YES") or disable ("NO", the default) this startup script.
+#
+
+. %%RC_SUBR%%
+
+name="mu_conference"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/mu-conference"
+pidfile="/var/jabberd/pid/mu-conference.pid"
+
+stop_postcmd="mu_conference_stop_post"
+
+mu_conference_stop_post () {
+ rm -f ${pidfile}
+}
+
+load_rc_config $name
+
+: ${mu_conference_config="%%PREFIX%%/etc/muc.xml"}
+: ${mu_conference_enable="NO"}
+: ${mu_conference_user="jabber"}
+
+command_args="-c $mu_conference_config -B"
+
+run_rc_command "$1"
+