aboutsummaryrefslogtreecommitdiff
path: root/net-im/openfire/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-28 23:05:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-28 23:05:41 +0000
commitfd52d191327a9f4daf587ac87570081eed7b757c (patch)
treec0d9e4efed0f988310911e2a4658d79035b03fc3 /net-im/openfire/Makefile
parent7d8c4a26c42bf259e9a30956b9824efc5acee22c (diff)
downloadports-fd52d191327a9f4daf587ac87570081eed7b757c.tar.gz
ports-fd52d191327a9f4daf587ac87570081eed7b757c.zip
Notes
Diffstat (limited to 'net-im/openfire/Makefile')
-rw-r--r--net-im/openfire/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index 9eaef699eed7..a5b52a747b21 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openfire
-PORTVERSION= 3.3.1
-PORTREVISION= 1
+PORTVERSION= 3.3.2
CATEGORIES= net-im java
MASTER_SITES= http://www.igniterealtime.org/downloadServlet?filename=openfire/
DISTNAME= ${PORTNAME}_src_${PORTVERSION:S/./_/g}
@@ -37,8 +36,9 @@ PUSER= openfire
PGROUP= ${PUSER}
MLINKS= ${VARLOG} ${DATADIR}/logs \
- ${VARDB} ${DATADIR}/embedded-db \
- ${ETCDIR} ${DATADIR}/conf
+ ${VARDB} ${DATADIR}/embedded-db \
+ ${ETCDIR} ${DATADIR}/conf \
+ ${ETCDIR} ${DATADIR}/resources/security
do-install:
@@ -49,7 +49,7 @@ do-install:
${MKDIR} ${VARLOG};
${MKDIR} ${VARDB};
- (cd ${INSTALL_WRKSRC}/resources && ${FIND} . \
+ (cd ${INSTALL_WRKSRC}/resources && ${FIND} . \! -path ./security\* \
| ${CPIO} -pvdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}/resources)
(cd ${INSTALL_WRKSRC}/plugins && ${FIND} . \
@@ -67,10 +67,22 @@ do-install:
post-install:
${MKDIR} ${EXAMPLESDIR};
${CP} -p ${INSTALL_WRKSRC}/conf/openfire.xml ${EXAMPLESDIR}/openfire.xml
+ ${CP} -p ${INSTALL_WRKSRC}/resources/security/truststore \
+ ${EXAMPLESDIR}/truststore
+ ${CP} -p ${INSTALL_WRKSRC}/resources/security/keystore \
+ ${EXAMPLESDIR}/keystore
@if [ ! -f ${ETCDIR}/openfire.xml ]; then \
${MKDIR} ${ETCDIR}; \
${CP} -p ${INSTALL_WRKSRC}/conf/openfire.xml ${ETCDIR}/openfire.xml; \
fi
+ @if [ ! -f ${ETCDIR}/keystore ]; then \
+ ${CP} -p ${INSTALL_WRKSRC}/resources/security/keystore \
+ ${ETCDIR}/keystore; \
+ fi
+ @if [ ! -f ${ETCDIR}/truststore ]; then \
+ ${CP} -p ${INSTALL_WRKSRC}/resources/security/truststore \
+ ${ETCDIR}/truststore; \
+ fi
@PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
${CHOWN} -R ${PUSER}:${PGROUP} ${ETCDIR}
${CHOWN} -R ${PUSER}:${PGROUP} ${VARDB}