aboutsummaryrefslogtreecommitdiff
path: root/net-im/openfire
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-03-22 08:05:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-03-22 08:05:12 +0000
commiteb3a86b25ed8e88d1ff9c7be386854220cf69a29 (patch)
tree4a7d2f84c09e2b816f4b66c719d928260b4fbae7 /net-im/openfire
parentc691641e0b5bc184a230f7dc4d797b6dbdace35d (diff)
downloadports-eb3a86b25ed8e88d1ff9c7be386854220cf69a29.tar.gz
ports-eb3a86b25ed8e88d1ff9c7be386854220cf69a29.zip
Notes
Diffstat (limited to 'net-im/openfire')
-rw-r--r--net-im/openfire/Makefile28
-rw-r--r--net-im/openfire/distinfo4
-rw-r--r--net-im/openfire/files/patch-build-build.xml10
-rw-r--r--net-im/openfire/files/pkg-message.in4
-rw-r--r--net-im/openfire/pkg-install30
-rw-r--r--net-im/openfire/pkg-message2
-rw-r--r--net-im/openfire/pkg-plist42
7 files changed, 50 insertions, 70 deletions
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index 4fdacb7797d0..906439742787 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= openfire
-PORTVERSION= 3.6.4
+PORTVERSION= 3.7.0
PORTEPOCH= 1
CATEGORIES= net-im java
-MASTER_SITES= http://download.igniterealtime.org/openfire/
+MASTER_SITES= http://www.igniterealtime.org/downloadServlet?filename=openfire/
DISTNAME= ${PORTNAME}_src_${PORTVERSION:S/./_/g}
MAINTAINER= gahr@FreeBSD.org
-COMMENT= Openfire (formerly Wildfire) is an enterprise instant messaging server
+COMMENT= Enterprise instant messaging server
-RUN_DEPENDS= classpath:${PORTSDIR}/java/javavmwrapper
+RUN_DEPENDS= classpath:${PORTSDIR}/java/javavmwrapper \
+ ${JAVAJARDIR}/slf4j-api.jar:${PORTSDIR}/devel/slf4j
USE_LDCONFIG= yes
USE_ANT= yes
@@ -24,9 +25,8 @@ JAVA_VERSION= 1.5+
CONFLICTS= wildfire-[0-9]*
-ALL_TARGET= openfire
+ALL_TARGET= openfire plugins
USE_RC_SUBR= openfire
-SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}_src
BUILD_WRKSRC= ${WRKSRC}/build
@@ -34,8 +34,8 @@ INSTALL_WRKSRC= ${WRKSRC}/target/openfire
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
VARLOG= /var/log/openfire
VARDB= /var/db/openfire
-PUSER= openfire
-PGROUP= ${PUSER}
+USERS= openfire
+GROUPS= ${USERS}
do-install:
@@ -88,16 +88,12 @@ post-install:
${INSTALL} -m 600 ${INSTALL_WRKSRC}/resources/security/truststore \
${ETCDIR}/truststore; \
fi
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- ${CHOWN} -Rh ${PUSER}:${PGROUP} ${ETCDIR}
- ${CHOWN} -Rh ${PUSER}:${PGROUP} ${VARDB}
- ${CHOWN} -Rh ${PUSER}:${PGROUP} ${VARLOG}
- ${CHOWN} -Rh ${PUSER}:${PGROUP} ${DATADIR}
+ ${CHOWN} -Rh ${USERS}:${GROUPS} ${ETCDIR}
+ ${CHOWN} -Rh ${USERS}:${GROUPS} ${VARDB}
+ ${CHOWN} -Rh ${USERS}:${GROUPS} ${VARLOG}
+ ${CHOWN} -Rh ${USERS}:${GROUPS} ${DATADIR}
- @${ECHO_CMD} "===> post-installation information for ${PKGNAME}:"
- @${ECHO_CMD} ""
@${CAT} ${PKGMESSAGE}
- @${ECHO_CMD} ""
.include <bsd.port.mk>
diff --git a/net-im/openfire/distinfo b/net-im/openfire/distinfo
index 3114b2123c3a..61fe8ae82987 100644
--- a/net-im/openfire/distinfo
+++ b/net-im/openfire/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openfire_src_3_6_4.tar.gz) = 8f5c3334da449e2fb1bdabe2bdd46db1fd96a4dc7b3e34a870401fa90819ea99
-SIZE (openfire_src_3_6_4.tar.gz) = 51183844
+SHA256 (openfire_src_3_7_0.tar.gz) = 838606343b06059cee7d98b9e0d989dc511021b64e0c24a3379192e763b9ef4a
+SIZE (openfire_src_3_7_0.tar.gz) = 60928248
diff --git a/net-im/openfire/files/patch-build-build.xml b/net-im/openfire/files/patch-build-build.xml
deleted file mode 100644
index 341c52a77fb7..000000000000
--- a/net-im/openfire/files/patch-build-build.xml
+++ /dev/null
@@ -1,10 +0,0 @@
---- build/build.xml.orig 2010-10-27 04:53:55.000000000 -0700
-+++ build/build.xml 2010-10-27 04:54:13.000000000 -0700
-@@ -224,6 +224,7 @@
- <or>
- <contains string="${ant.version}" substring="1.6"/>
- <contains string="${ant.version}" substring="1.7"/>
-+ <contains string="${ant.version}" substring="1.8"/>
- </or>
- </not>
- </condition>
diff --git a/net-im/openfire/files/pkg-message.in b/net-im/openfire/files/pkg-message.in
deleted file mode 100644
index 0fb1c4ea116f..000000000000
--- a/net-im/openfire/files/pkg-message.in
+++ /dev/null
@@ -1,4 +0,0 @@
-You can find the documentation files for this package in
-%%DOCSDIR%%.
-To enable openfire startup script please add openfire_enable="YES" in
-your rc.conf file.
diff --git a/net-im/openfire/pkg-install b/net-im/openfire/pkg-install
deleted file mode 100644
index b3f53f44b88f..000000000000
--- a/net-im/openfire/pkg-install
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-
-case $2 in
-POST-INSTALL)
- PUSER=openfire
- PGROUP=${PUSER}
- PUID=342
- PGID=${PUID}
-
- if ! pw group show "${PGROUP}" > /dev/null; then
- if pw groupadd ${PGROUP} -g ${PGID}; then
- echo "Added group \"${PGROUP}\"."
- else
- echo "Adding group \"${PGROUP}\" failed..."
- exit 1
- fi
- fi
-
- if ! pw user show "${PUSER}" > /dev/null; then
- if pw useradd ${PUSER} -u ${PUID} -g ${PGROUP} -h - \
- -d /nonexistent -s /sbin/nologin -c "Openfire Daemon"
- then
- echo "Added user \"${PUSER}\"."
- else
- echo "Adding user \"${PUSER}\" failed..."
- exit 1
- fi
- fi
- ;;
-esac
diff --git a/net-im/openfire/pkg-message b/net-im/openfire/pkg-message
new file mode 100644
index 000000000000..83786ae05fce
--- /dev/null
+++ b/net-im/openfire/pkg-message
@@ -0,0 +1,2 @@
+To enable the openfire startup script please add
+openfire_enable="YES" to your /etc/rc.conf file.
diff --git a/net-im/openfire/pkg-plist b/net-im/openfire/pkg-plist
index b5b68eb107c9..329354301201 100644
--- a/net-im/openfire/pkg-plist
+++ b/net-im/openfire/pkg-plist
@@ -55,6 +55,7 @@
%%JAVAJARDIR%%/postgres.jar
%%JAVAJARDIR%%/servlet.jar
%%JAVAJARDIR%%/startup.jar
+%%JAVAJARDIR%%/slf4j-log4j12.jar
%%DATADIR%%/conf
%%DATADIR%%/embedded-db
%%DATADIR%%/logs
@@ -218,6 +219,26 @@
%%DATADIR%%/plugins/admin/webapp/style/lightbox.css
%%DATADIR%%/plugins/admin/webapp/style/login.css
%%DATADIR%%/plugins/admin/webapp/style/setup.css
+%%DATADIR%%/plugins/broadcast.jar
+%%DATADIR%%/plugins/clientControl.jar
+%%DATADIR%%/plugins/contentFilter.jar
+%%DATADIR%%/plugins/dbaccess.jar
+%%DATADIR%%/plugins/emailListener.jar
+%%DATADIR%%/plugins/fastpath.jar
+%%DATADIR%%/plugins/jingleNodes.jar
+%%DATADIR%%/plugins/loadStats.jar
+%%DATADIR%%/plugins/monitoring.jar
+%%DATADIR%%/plugins/motd.jar
+%%DATADIR%%/plugins/packetFilter.jar
+%%DATADIR%%/plugins/presence.jar
+%%DATADIR%%/plugins/registration.jar
+%%DATADIR%%/plugins/search.jar
+%%DATADIR%%/plugins/sip.jar
+%%DATADIR%%/plugins/subscription.jar
+%%DATADIR%%/plugins/userCreation.jar
+%%DATADIR%%/plugins/userImportExport.jar
+%%DATADIR%%/plugins/userservice.jar
+%%DATADIR%%/plugins/xmldebugger.jar
%%DATADIR%%/resources/database/openfire_db2.sql
%%DATADIR%%/resources/database/openfire_hsqldb.sql
%%DATADIR%%/resources/database/openfire_mysql.sql
@@ -314,6 +335,13 @@
%%DATADIR%%/resources/database/upgrade/20/openfire_postgresql.sql
%%DATADIR%%/resources/database/upgrade/20/openfire_sqlserver.sql
%%DATADIR%%/resources/database/upgrade/20/openfire_sybase.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_db2.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_hsqldb.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_mysql.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_oracle.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_postgresql.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_sqlserver.sql
+%%DATADIR%%/resources/database/upgrade/21/openfire_sybase.sql
%%DATADIR%%/resources/database/upgrade/4/openfire_db2.sql
%%DATADIR%%/resources/database/upgrade/4/openfire_hsqldb.sql
%%DATADIR%%/resources/database/upgrade/4/openfire_mysql.sql
@@ -376,6 +404,7 @@
@dirrm %%DATADIR%%/resources/database/upgrade/6
@dirrm %%DATADIR%%/resources/database/upgrade/5
@dirrm %%DATADIR%%/resources/database/upgrade/4
+@dirrm %%DATADIR%%/resources/database/upgrade/21
@dirrm %%DATADIR%%/resources/database/upgrade/20
@dirrm %%DATADIR%%/resources/database/upgrade/2
@dirrm %%DATADIR%%/resources/database/upgrade/19
@@ -402,15 +431,12 @@
@dirrm %%DATADIR%%/plugins/admin/webapp/WEB-INF
@dirrm %%DATADIR%%/plugins/admin/webapp
@dirrm %%DATADIR%%/plugins/admin
-@dirrm %%DATADIR%%/plugins
-@dirrm share/java/openfire
-@dirrm share/examples/openfire
-@dirrm %%PORTDOCS%%%%DOCSDIR%%/licenses
-@dirrm %%PORTDOCS%%%%DOCSDIR%%/images
-@dirrm share/doc/openfire
-@comment @dirrm %%ETCDIR%%/openfire
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/licenses
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@unexec rmdir %D/%%DATADIR%%/plugins 2> /dev/null || echo "If permanently deleting this package, %D/%%DATADIR%%/plugins must be removed manually"
+@unexec rmdir %D/%%DATADIR%% 2> /dev/null
@unexec rmdir %D/%%ETCDIR%% 2> /dev/null || echo "If permanently deleting this package, %D/%%ETCDIR%% must be removed manually"
@unexec rmdir /var/db/openfire 2> /dev/null || echo "If permanently deleting this package, /var/db/openfire must be removed manually"
@unexec rmdir /var/log/openfire 2> /dev/null || echo "If permanently deleting this package, /var/log/openfire must be removed manually"
-@dirrmtry %%DATADIR%%