aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Jabber-Connection
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-02 07:14:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-02 07:14:17 +0000
commitc3d050563b3af33b389363cb2fdc5feabf953f0f (patch)
tree7d29b7479ec660943c91417173ff6f77f94eeed8 /net-im/p5-Jabber-Connection
parent087ef6b24788a4be559c71159e0d77fa4a69e6ac (diff)
downloadports-c3d050563b3af33b389363cb2fdc5feabf953f0f.tar.gz
ports-c3d050563b3af33b389363cb2fdc5feabf953f0f.zip
Notes
Diffstat (limited to 'net-im/p5-Jabber-Connection')
-rw-r--r--net-im/p5-Jabber-Connection/Makefile27
-rw-r--r--net-im/p5-Jabber-Connection/distinfo1
-rw-r--r--net-im/p5-Jabber-Connection/pkg-descr7
-rw-r--r--net-im/p5-Jabber-Connection/pkg-plist7
4 files changed, 42 insertions, 0 deletions
diff --git a/net-im/p5-Jabber-Connection/Makefile b/net-im/p5-Jabber-Connection/Makefile
new file mode 100644
index 000000000000..46bbb62aee01
--- /dev/null
+++ b/net-im/p5-Jabber-Connection/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Jabber-Connection
+# Date created: 01 October 2003
+# Whom: Lars Eggert
+#
+# $FreeBSD$
+#
+
+PORTNAME= Jabber-Connection
+PORTVERSION= 0.04
+CATEGORIES= net perl5
+#MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= Jabber
+MASTER_SITES= http://www.pipetree.com/jabber/jabberconnection/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= larse@isi.edu
+COMMENT= Jabber Perl library for client/component connectivity
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Jabber::Connection.3 Jabber::NS.3 Jabber::NodeFactory.3
+
+.include <bsd.port.mk>
diff --git a/net-im/p5-Jabber-Connection/distinfo b/net-im/p5-Jabber-Connection/distinfo
new file mode 100644
index 000000000000..d8d011f167cf
--- /dev/null
+++ b/net-im/p5-Jabber-Connection/distinfo
@@ -0,0 +1 @@
+MD5 (Jabber-Connection-0.04.tar.gz) = ab9a85df88637f6bc542a38ac0501d8e
diff --git a/net-im/p5-Jabber-Connection/pkg-descr b/net-im/p5-Jabber-Connection/pkg-descr
new file mode 100644
index 000000000000..ded4fcdf7811
--- /dev/null
+++ b/net-im/p5-Jabber-Connection/pkg-descr
@@ -0,0 +1,7 @@
+Jabber::Connection
+
+Jabber::Connection is a new Perl library for Jabber that provides
+the basic features for client and component connectivity, plus an
+xmlnode-like library for flexibly manipulating Jabber elements.
+
+WWW: http://www.pipetree.com/jabber/jabberconnection/
diff --git a/net-im/p5-Jabber-Connection/pkg-plist b/net-im/p5-Jabber-Connection/pkg-plist
new file mode 100644
index 000000000000..cfb62bb10f1e
--- /dev/null
+++ b/net-im/p5-Jabber-Connection/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Jabber/Connection.pm
+%%SITE_PERL%%/Jabber/NS.pm
+%%SITE_PERL%%/Jabber/NodeFactory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber/Connection/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber/Connection
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber
+@dirrm %%SITE_PERL%%/Jabber