aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Net-Async-XMPP/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-07 15:39:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-07 15:39:15 +0000
commit8f4240402bd8d6d2f6363d5be98576210601f222 (patch)
treee9921898d2b17bb7b96860d7e1f98d7f56688782 /net-im/p5-Net-Async-XMPP/Makefile
parent795ce42418ac6201834214a3fa9ff61a8991cb73 (diff)
downloadports-8f4240402bd8d6d2f6363d5be98576210601f222.tar.gz
ports-8f4240402bd8d6d2f6363d5be98576210601f222.zip
Notes
Diffstat (limited to 'net-im/p5-Net-Async-XMPP/Makefile')
-rw-r--r--net-im/p5-Net-Async-XMPP/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-im/p5-Net-Async-XMPP/Makefile b/net-im/p5-Net-Async-XMPP/Makefile
new file mode 100644
index 000000000000..29bb325e3772
--- /dev/null
+++ b/net-im/p5-Net-Async-XMPP/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-Async-XMPP
+# Date created: 2011-03-07
+# Whom: <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Async-XMPP
+PORTVERSION= 0.002
+CATEGORIES= net-im perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TEAM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Asynchronous XMPP client and server
+
+RUN_DEPENDS= p5-IO-Async>=0.37:${PORTSDIR}/devel/p5-IO-Async \
+ p5-IO-Async-SSL>=0.04:${PORTSDIR}/security/p5-IO-Async-SSL \
+ p5-Protocol-XMPP>=0.002:${PORTSDIR}/net-im/p5-Protocol-XMPP \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Async::XMPP.3 \
+ Net::Async::XMPP::Client.3 \
+ Net::Async::XMPP::Protocol.3 \
+ Net::Async::XMPP::Server.3
+
+.include <bsd.port.mk>