aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Net-XMPP/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2008-01-04 23:48:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2008-01-04 23:48:20 +0000
commiteb2a97ed047f55e287b9aad69f22754aa6348ebe (patch)
treeaa999ca754661c28418a05c4ccae674784ad7475 /net-im/p5-Net-XMPP/Makefile
parent36606728a87054204f4f1aa49a42f7be0adb77a2 (diff)
downloadports-eb2a97ed047f55e287b9aad69f22754aa6348ebe.tar.gz
ports-eb2a97ed047f55e287b9aad69f22754aa6348ebe.zip
Notes
Diffstat (limited to 'net-im/p5-Net-XMPP/Makefile')
-rw-r--r--net-im/p5-Net-XMPP/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-im/p5-Net-XMPP/Makefile b/net-im/p5-Net-XMPP/Makefile
index a678de7b08f4..5ea0ba1b947d 100644
--- a/net-im/p5-Net-XMPP/Makefile
+++ b/net-im/p5-Net-XMPP/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= Net-XMPP
-PORTVERSION= 1.0
+PORTVERSION= 1.02
CATEGORIES= net-im perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Net
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= lars.eggert@gmx.net
+MAINTAINER= perl@FreeBSD.org
COMMENT= Net::XMPP provides Perl Developer access to the XMPP protocol
-BUILD_DEPENDS= ${SITE_PERL}/XML/Stream.pm:${PORTSDIR}/textproc/p5-XML-Stream \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+BUILD_DEPENDS= p5-XML-Stream>=1.22:${PORTSDIR}/textproc/p5-XML-Stream \
+ p5-Digest-SHA1>=1.02:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.8.0+ # Require perl 5.8.x due to XML::Stream
+USE_PERL5= 5.8.0+ # Require perl 5.8.x due to XML::Stream
+PERL_MODBUILD= yes
MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
Net::XMPP::Debug.3 Net::XMPP::IQ.3 Net::XMPP::JID.3 \