aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-SOAP-Transport-JABBER
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-22 16:24:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-22 16:24:00 +0000
commit2e9cf86464299e59ae7d6017d1a92d5bb66efb04 (patch)
treeb9b3c8afb75ef0f9167572196e755e3b885499b9 /net-im/p5-SOAP-Transport-JABBER
parent9eba8f55eac8d0f070f0d11200e7227c87031e85 (diff)
downloadports-2e9cf86464299e59ae7d6017d1a92d5bb66efb04.tar.gz
ports-2e9cf86464299e59ae7d6017d1a92d5bb66efb04.zip
Notes
Diffstat (limited to 'net-im/p5-SOAP-Transport-JABBER')
-rw-r--r--net-im/p5-SOAP-Transport-JABBER/Makefile32
-rw-r--r--net-im/p5-SOAP-Transport-JABBER/distinfo2
-rw-r--r--net-im/p5-SOAP-Transport-JABBER/pkg-descr10
-rw-r--r--net-im/p5-SOAP-Transport-JABBER/pkg-plist7
4 files changed, 51 insertions, 0 deletions
diff --git a/net-im/p5-SOAP-Transport-JABBER/Makefile b/net-im/p5-SOAP-Transport-JABBER/Makefile
new file mode 100644
index 000000000000..d6eff3a78e8f
--- /dev/null
+++ b/net-im/p5-SOAP-Transport-JABBER/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-SOAP-Transport-JABBER
+# Date created: 2011-08-20
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP-Transport-JABBER
+PORTVERSION= 0.713
+CATEGORIES= net-im net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A Jabber-based transport backend for SOAP::Lite
+
+BUILD_DEPENDS= p5-Net-Jabber>=0:${PORTSDIR}/net-im/p5-Net-Jabber \
+ p5-SOAP-Lite>=0.711:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= p5-Net-Jabber>=0:${PORTSDIR}/net-im/p5-Net-Jabber \
+ p5-SOAP-Lite>=0.711:${PORTSDIR}/net/p5-SOAP-Lite
+
+PERL_CONFIGURE= yes
+
+MAN3= SOAP::Transport::JABBER.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-Module-Build>=0.3600:${PORTSDIR}/devel/p5-Module-Build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/p5-SOAP-Transport-JABBER/distinfo b/net-im/p5-SOAP-Transport-JABBER/distinfo
new file mode 100644
index 000000000000..e2a751b40bfd
--- /dev/null
+++ b/net-im/p5-SOAP-Transport-JABBER/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SOAP-Transport-JABBER-0.713.tar.gz) = df5f59eaf28948372ecfcfe5556296aee45d105c4cf4797da72a45d827fc11c3
+SIZE (SOAP-Transport-JABBER-0.713.tar.gz) = 37888
diff --git a/net-im/p5-SOAP-Transport-JABBER/pkg-descr b/net-im/p5-SOAP-Transport-JABBER/pkg-descr
new file mode 100644
index 000000000000..2b5a81116742
--- /dev/null
+++ b/net-im/p5-SOAP-Transport-JABBER/pkg-descr
@@ -0,0 +1,10 @@
+SOAP::Transport::JABBER provides a Jabber-based transport backend for
+SOAP::Lite.
+
+This class uses the Net::Jabber classes to abstract the Jabber protocol away
+from the direct notice of the application. Besides maintaining any needed
+objects internally, the package also uses a separate class as a proxy between
+communication layers, SOAP::Transport::JABBER::Query. The Jabber support
+provides both client and server classes.
+
+WWW: http://search.cpan.org/dist/SOAP-Transport-JABBER/
diff --git a/net-im/p5-SOAP-Transport-JABBER/pkg-plist b/net-im/p5-SOAP-Transport-JABBER/pkg-plist
new file mode 100644
index 000000000000..0a55cb26792b
--- /dev/null
+++ b/net-im/p5-SOAP-Transport-JABBER/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/SOAP/Transport/JABBER.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Transport/JABBER/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Transport/JABBER
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Transport
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP
+@dirrmtry %%SITE_PERL%%/SOAP/Transport
+@dirrmtry %%SITE_PERL%%/SOAP