aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-audacious-remote
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-02 11:46:09 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-02 11:46:09 +0000
commit774207781367939ced2890ec15b4c918d97ed6fd (patch)
treeb90509e966b36845109169a13dd17d1e05e72319 /net-im/pidgin-audacious-remote
parent29d1a70e66b7b84b3ba840e1aa020b80689c95c3 (diff)
downloadports-774207781367939ced2890ec15b4c918d97ed6fd.tar.gz
ports-774207781367939ced2890ec15b4c918d97ed6fd.zip
Notes
Diffstat (limited to 'net-im/pidgin-audacious-remote')
-rw-r--r--net-im/pidgin-audacious-remote/Makefile29
-rw-r--r--net-im/pidgin-audacious-remote/distinfo2
-rw-r--r--net-im/pidgin-audacious-remote/files/patch-pixmaps-Makefile.in11
-rw-r--r--net-im/pidgin-audacious-remote/pkg-descr3
-rw-r--r--net-im/pidgin-audacious-remote/pkg-plist13
5 files changed, 58 insertions, 0 deletions
diff --git a/net-im/pidgin-audacious-remote/Makefile b/net-im/pidgin-audacious-remote/Makefile
new file mode 100644
index 000000000000..15d9eb1047cc
--- /dev/null
+++ b/net-im/pidgin-audacious-remote/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pidgin-audacious-remote
+# Date created: 30 August 2011
+# Whom: Anton Hryciuk <gnixua@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pidgin-audacious-remote
+PORTVERSION= 0.5
+CATEGORIES= net-im
+MASTER_SITES= http://pidginaudacious.sourceforge.net/files/ \
+ ftp://ftp.lissyara.su/users/gx_ua/distfiles/
+#DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gnixua@gmail.com
+COMMENT= Pidgin-Audacious-Remote is a plug-in for Pidgin 2
+
+BUILD_DEPENDS= audacious>=2.2:${PORTSDIR}/multimedia/audacious \
+ pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+
+MAKE_JOBS_SAFE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= "--prefix=${PREFIX}"
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-audacious-remote/distinfo b/net-im/pidgin-audacious-remote/distinfo
new file mode 100644
index 000000000000..133e97b923ca
--- /dev/null
+++ b/net-im/pidgin-audacious-remote/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pidgin-audacious-remote-0.5.tar.bz2) = 94a5c073a25664377e4b9b34851c9029efa4d8b3e10629df4f3048766f664806
+SIZE (pidgin-audacious-remote-0.5.tar.bz2) = 251730
diff --git a/net-im/pidgin-audacious-remote/files/patch-pixmaps-Makefile.in b/net-im/pidgin-audacious-remote/files/patch-pixmaps-Makefile.in
new file mode 100644
index 000000000000..86d8bddf8b04
--- /dev/null
+++ b/net-im/pidgin-audacious-remote/files/patch-pixmaps-Makefile.in
@@ -0,0 +1,11 @@
+--- pixmaps/Makefile.in.orig 2011-10-02 11:01:51.000000000 +0200
++++ pixmaps/Makefile.in 2011-10-02 11:02:20.000000000 +0200
+@@ -163,7 +163,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-pixmapdir = /usr/share/pixmaps/pidgin/pidgin-audacious-remote
++pixmapdir = $(prefix)/share/pixmaps/pidgin/pidgin-audacious-remote
+ pixmap_DATA = audacious.png next.png pause.png play.png previous.png stop.png
+ all: all-am
+
diff --git a/net-im/pidgin-audacious-remote/pkg-descr b/net-im/pidgin-audacious-remote/pkg-descr
new file mode 100644
index 000000000000..1699bad40939
--- /dev/null
+++ b/net-im/pidgin-audacious-remote/pkg-descr
@@ -0,0 +1,3 @@
+Pidgin-Audacious-Remote is a plug-in for Pidgin 2.
+
+WWW: http://pidgin-audacious-remote.sourceforge.net/
diff --git a/net-im/pidgin-audacious-remote/pkg-plist b/net-im/pidgin-audacious-remote/pkg-plist
new file mode 100644
index 000000000000..93ca94fa098e
--- /dev/null
+++ b/net-im/pidgin-audacious-remote/pkg-plist
@@ -0,0 +1,13 @@
+lib/pidgin/pidgin-audacious-remote.a
+lib/pidgin/pidgin-audacious-remote.la
+lib/pidgin/pidgin-audacious-remote.so
+share/pixmaps/pidgin/pidgin-audacious-remote/audacious.png
+share/pixmaps/pidgin/pidgin-audacious-remote/next.png
+share/pixmaps/pidgin/pidgin-audacious-remote/pause.png
+share/pixmaps/pidgin/pidgin-audacious-remote/play.png
+share/pixmaps/pidgin/pidgin-audacious-remote/previous.png
+share/pixmaps/pidgin/pidgin-audacious-remote/stop.png
+@dirrm share/pixmaps/pidgin/pidgin-audacious-remote
+@dirrmtry share/pixmaps/pidgin
+@dirrmtry share/pixmaps
+@dirrmtry lib/pidgin