aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-hotkeys
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-05-21 17:01:40 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-05-21 17:01:40 +0000
commit42e391b20606152e818bd118cb233c166827603a (patch)
treeba9bb18671d152e6ca43d14851562cd42a741d98 /net-im/pidgin-hotkeys
parent7ad44913e14627b6ae929e2be4d4d5de8981baa3 (diff)
downloadports-42e391b20606152e818bd118cb233c166827603a.tar.gz
ports-42e391b20606152e818bd118cb233c166827603a.zip
Notes
Diffstat (limited to 'net-im/pidgin-hotkeys')
-rw-r--r--net-im/pidgin-hotkeys/Makefile12
-rw-r--r--net-im/pidgin-hotkeys/files/patch-configure12
-rw-r--r--net-im/pidgin-hotkeys/files/patch-src_Makefile.in11
-rw-r--r--net-im/pidgin-hotkeys/files/patch-src_hotkeys.c34
4 files changed, 63 insertions, 6 deletions
diff --git a/net-im/pidgin-hotkeys/Makefile b/net-im/pidgin-hotkeys/Makefile
index 43da30f81de8..28b70e608155 100644
--- a/net-im/pidgin-hotkeys/Makefile
+++ b/net-im/pidgin-hotkeys/Makefile
@@ -7,21 +7,21 @@
PORTNAME= gaim-hotkeys
PORTVERSION= 0.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= A gaim plugin that allows user to assign global hotkeys
-LIB_DEPENDS= gaim.0:${PORTSDIR}/net-im/libpurple
-BUILD_DEPENDS= gaim:${PORTSDIR}/net-im/pidgin
-RUN_DEPENDS= gaim:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= purple.0:${PORTSDIR}/net-im/libpurple
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
USE_GNOME= pkgconfig gtk20
GNU_CONFIGURE= yes
-PLIST_FILES= lib/gaim/hotkeys.so \
- lib/gaim/hotkeys.la
+PLIST_FILES= lib/pidgin/hotkeys.so \
+ lib/pidgin/hotkeys.la
.include <bsd.port.mk>
diff --git a/net-im/pidgin-hotkeys/files/patch-configure b/net-im/pidgin-hotkeys/files/patch-configure
new file mode 100644
index 000000000000..6799a99729c0
--- /dev/null
+++ b/net-im/pidgin-hotkeys/files/patch-configure
@@ -0,0 +1,12 @@
+--- ../gaim-hotkeys-0.2.2.orig/configure Mon May 7 09:02:50 2007
++++ configure Mon May 7 09:03:46 2007
+@@ -19868,7 +19868,7 @@
+
+
+ gtk_modules="gtk+-2.0 >= 2.4.0"
+-gaim_modules="gaim >= 2.0.0"
++gaim_modules="pidgin >= 2.0.0"
+
+
+ if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
+diff -ruN ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c ./src/hotkeys.c
diff --git a/net-im/pidgin-hotkeys/files/patch-src_Makefile.in b/net-im/pidgin-hotkeys/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..7e664f08c96b
--- /dev/null
+++ b/net-im/pidgin-hotkeys/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- ../gaim-hotkeys-0.2.2.orig/src/Makefile.in Mon May 7 09:02:50 2007
++++ src/Makefile.in Mon May 7 09:20:48 2007
+@@ -220,7 +220,7 @@
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+-plugindir = $(libdir)/gaim
++plugindir = $(libdir)/pidgin
+ hotkeys_la_LDFLAGS = -module -avoid-version $(am__append_1)
+ hotkeys_la_LIBADD = $(GAIM_LIBS) $(GTK_LIBS) $(am__append_2)
+ plugin_LTLIBRARIES = hotkeys.la
diff --git a/net-im/pidgin-hotkeys/files/patch-src_hotkeys.c b/net-im/pidgin-hotkeys/files/patch-src_hotkeys.c
new file mode 100644
index 000000000000..0fdd4ab13578
--- /dev/null
+++ b/net-im/pidgin-hotkeys/files/patch-src_hotkeys.c
@@ -0,0 +1,34 @@
+--- ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c Mon May 7 09:02:50 2007
++++ src/hotkeys.c Mon May 7 09:20:48 2007
+@@ -22,15 +22,21 @@
+ #include <gdk/gdkkeysyms.h>
+
+ #define GAIM_PLUGINS
+-#include <gaim.h>
+-#include <gaim/version.h>
+-#include <gaim/debug.h>
+-#include <gaim/gtkblist.h>
+-#include <gaim/gtkplugin.h>
+-#include <gaim/gtkutils.h>
+-#include <gaim/gtkdialogs.h>
+-#include <gaim/gtkprefs.h>
+-#include <gaim/gtkaccount.h>
++#include <pidgin.h>
++
++#include <libpurple/gaim-compat.h>
++#include <libpurple/conversation.h>
++#include <libpurple/debug.h>
++#include <libpurple/version.h>
++
++#include <pidgin/gtkgaim-compat.h>
++#include <pidgin/gtkconv.h>
++#include <pidgin/gtkblist.h>
++#include <pidgin/gtkplugin.h>
++#include <pidgin/gtkutils.h>
++#include <pidgin/gtkdialogs.h>
++#include <pidgin/gtkprefs.h>
++#include <pidgin/gtkaccount.h>
+
+ #ifdef GDK_WINDOWING_X11
+ #include <X11/keysym.h>
+diff -ruN ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c ./src/hotkeys.c