aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-rocketchat
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-10-20 16:01:58 +0000
committerSteve Wills <swills@FreeBSD.org>2017-10-20 16:01:58 +0000
commit96f751729ac6e83deee66e41d788f462f1559e09 (patch)
tree82914e272dc5ce0c14a76830a21e9971f7e10936 /net-im/pidgin-rocketchat
parented0b27a16847c3225a671d3995852a4063a8e6c6 (diff)
downloadports-96f751729ac6e83deee66e41d788f462f1559e09.tar.gz
ports-96f751729ac6e83deee66e41d788f462f1559e09.zip
Notes
Diffstat (limited to 'net-im/pidgin-rocketchat')
-rw-r--r--net-im/pidgin-rocketchat/Makefile30
-rw-r--r--net-im/pidgin-rocketchat/distinfo3
-rw-r--r--net-im/pidgin-rocketchat/pkg-descr4
3 files changed, 37 insertions, 0 deletions
diff --git a/net-im/pidgin-rocketchat/Makefile b/net-im/pidgin-rocketchat/Makefile
new file mode 100644
index 000000000000..b69cf59b4415
--- /dev/null
+++ b/net-im/pidgin-rocketchat/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= pidgin-rocketchat
+PORTVERSION= 0.0.20171004
+CATEGORIES= net-im
+MASTER_SITES= https://bitbucket.org/EionRobb/purple-rocketchat/get/
+DISTNAME= fb8dcc649782
+
+MAINTAINER= mizhka@gmail.com
+COMMENT= Rocket.Chat Plugin for libpurple
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
+ libpurple.so:net-im/libpurple
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmarkdown.a:textproc/discount
+RUN_DEPENDS= pidgin:net-im/pidgin
+
+USES= gmake pkgconfig zip
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/pidgin/librocketchat.so
+WRKSRC= ${WRKDIR}/EionRobb-purple-rocketchat-${DISTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/pidgin
+ ${INSTALL_LIB} ${WRKSRC}/librocketchat.so ${STAGEDIR}${PREFIX}/lib/pidgin
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-rocketchat/distinfo b/net-im/pidgin-rocketchat/distinfo
new file mode 100644
index 000000000000..ca9ff992e34a
--- /dev/null
+++ b/net-im/pidgin-rocketchat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507146563
+SHA256 (fb8dcc649782.zip) = fd918356721c8b87ec039a5cb09aab8c5810d431caf7e1c15b95ebe15b534829
+SIZE (fb8dcc649782.zip) = 50260
diff --git a/net-im/pidgin-rocketchat/pkg-descr b/net-im/pidgin-rocketchat/pkg-descr
new file mode 100644
index 000000000000..6a1c2f824a85
--- /dev/null
+++ b/net-im/pidgin-rocketchat/pkg-descr
@@ -0,0 +1,4 @@
+pidgin-rocketchar is libpurple plugin which adds support for Rocket.Char
+to the users who use pidgin
+
+WWW: https://bitbucket.org/EionRobb/purple-rocketchat