aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-skype/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-17 16:57:14 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-17 16:57:14 +0000
commit5795addbba9b9a79c66ce201661b96c571e7ef40 (patch)
treeeae79d4f3cebba3d0e91ecad3c25f200503106b5 /net-im/pidgin-skype/Makefile
parent6462719ce3f9f3a042e8bf6ca531e9b2e8211d5c (diff)
Convert net-im/libpurple (and slave ports net-im/finch and net-im/pidgin)
to "USES=libtool tar:bzip2". Bump PORTREVISION on all dependent ports and modernise them as well (USES, LIB_DEPENDS, staging). audio/pidgin-musictracker: - Replace LIBS with LDFLAGS. - Disable static plugin. net/online-desktop: Remove obsolete patches. net-im/mbpurple: - Drop pkgconf dependency. - Replace post-patch with MAKE_ARGS. - Use standard do-build. net-im/pidgin-audacious-remote: Disable static plugin. net-im/pidgin-birthday-reminder: Disable static plugin. net-im/pidgin-fetion: Replace pkg-plist with PLIST_FILES. net-im/pidgin-guifications: - Drop USE_GNOME=gnomeprefix. - Replace LIBS with LDFLAGS. net-im/pidgin-hotkeys: - Drop CFLAGS=-fPIC. - Fix build on systems without gcc. net-im/pidgin-libnotify: - Use option helpers. - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. net-im/pidgin-manualsize: Fix build on systems without gcc. net-im/pidgin-privacy-please: - Replace a patch with CPPFLAGS and LDFLAGS. - Don't use USE_LDCONFIG for a plugin. net-im/pidgin-sipe: - Don't use USE_LDCONFIG for a plugin. - Drop PORTDOCS that don't contain useful documentation. - Patch configure with s/LDLAGS/LDFLAGS/ so LDFLAGS can replace LIBS. - Use option helpers and fix Kerberos option. - Remove obsolete CONFIGURE_ENV. security/pidgin-encryption: - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Disable static plugin. - Use option helpers. security/pidgin-otr: - Drop redundant comment about PORTREVISION. - Add USE_GNOME=gtk20. - Drop references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Port uses stack protector unconditionally so link with -lssp_nonshared when necessary like Mk/bsd.ssp.mk does. Approved by: portmgr (PORTREVISION bump on unstaged port)
Notes
Notes: svn path=/head/; revision=354341
Diffstat (limited to 'net-im/pidgin-skype/Makefile')
-rw-r--r--net-im/pidgin-skype/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-im/pidgin-skype/Makefile b/net-im/pidgin-skype/Makefile
index 1c94b39db2d8..b9f905a452c9 100644
--- a/net-im/pidgin-skype/Makefile
+++ b/net-im/pidgin-skype/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pidgin-skype
PORTVERSION= 0.0.0.664
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= LOCAL/mandree
DISTFILES= pidgin-skype-svn-r${PORTVERSION:E}.tar.xz
@@ -17,9 +18,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin \
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
${LOCALBASE}/bin/skype:${PORTSDIR}/net-im/skype
-USES= gmake pkgconfig
+USES= gmake pkgconfig tar:xz
USE_GNOME= glib20
-USE_XZ= yes
# this is a local target to build a tarball
build-tarball: ${DISTFILES}
@@ -66,7 +66,7 @@ do-build:
cd ${WRKSRC} && ${CC} ${CPPFLAGS} ${CFLAGS} ${mycflags} \
-o libskype.so libskype.c ${mylibs}
.if ${PORT_OPTIONS:MNLS}
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} -C ${BUILD_WRKSRC} locales
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} -C ${BUILD_WRKSRC} locales
.endif
do-install: