aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-skype
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-12-14 10:04:52 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-12-14 10:04:52 +0000
commitebba1c6c16c25810b31639a8d753972da04ae0e5 (patch)
tree7a3d03bfd6117074e8ad44d446eec4035e9c235d /net-im/pidgin-skype
parent44248d8679cdce6963d8e4fc7bc4958d514a8841 (diff)
Notes
Diffstat (limited to 'net-im/pidgin-skype')
-rw-r--r--net-im/pidgin-skype/Makefile23
-rw-r--r--net-im/pidgin-skype/distinfo4
-rw-r--r--net-im/pidgin-skype/pkg-plist4
3 files changed, 16 insertions, 15 deletions
diff --git a/net-im/pidgin-skype/Makefile b/net-im/pidgin-skype/Makefile
index 7cb035abab3d..56c245155c7d 100644
--- a/net-im/pidgin-skype/Makefile
+++ b/net-im/pidgin-skype/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pidgin-skype
-PORTVERSION= 0.0.0.659
+PORTVERSION= 0.0.0.664
CATEGORIES= net-im
MASTER_SITES= LOCAL/mandree
DISTFILES= pidgin-skype-svn-r${PORTVERSION:E}.tar.xz
@@ -17,13 +17,12 @@ BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin \
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
${LOCALBASE}/bin/skype:${PORTSDIR}/net-im/skype
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= glib20
USE_XZ= yes
# this is a local target to build a tarball
build-tarball: ${DISTFILES}
-NO_STAGE= yes
${DISTFILES}:
${RM} -rf ${WRKSRC}
svn export -r${PORTVERSION:E} \
@@ -42,8 +41,6 @@ mycflags= -shared -fPIC -DPIC ${PTHREAD_CFLAGS} \
-DPURPLE_PLUGINS
mylibs= ${PTHREAD_LIBS}
-USES= pkgconfig
-
# DBUS: No DBUS here, does not work with Skype 2.1 beta
# NLS: While the build works and enables translations,
# the upstream translations and .pot file are woefully out of date.
@@ -71,20 +68,20 @@ do-build:
.endif
do-install:
- ${MKDIR} ${PREFIX}/lib/purple-2
- ${INSTALL_DATA} ${WRKSRC}/libskype.so ${PREFIX}/lib/purple-2
- ${MKDIR} ${PREFIX}/share/pixmaps/pidgin/emotes/skype
- ${INSTALL_DATA} ${WRKSRC}/theme ${PREFIX}/share/pixmaps/pidgin/emotes/skype
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/purple-2
+ ${INSTALL_PROGRAM} ${WRKSRC}/libskype.so ${STAGEDIR}${PREFIX}/lib/purple-2
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/emotes/skype
+ ${INSTALL_DATA} ${WRKSRC}/theme ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/emotes/skype
.for i in 16 22 48
- ${MKDIR} ${PREFIX}/share/pixmaps/pidgin/protocols/${i}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/protocols/${i}
${INSTALL_DATA} ${WRKSRC}/icons/${i}/skypeout.png \
${WRKSRC}/icons/${i}/skype.png \
- ${PREFIX}/share/pixmaps/pidgin/protocols/${i}/
+ ${STAGEDIR}${PREFIX}/share/pixmaps/pidgin/protocols/${i}/
.endfor
.if ${PORT_OPTIONS:MNLS}
.for i in cs de en_AU es fr hu it ja mk nb pl pt pt_BR ru
- ${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES/
- ${INSTALL_DATA} ${WRKSRC}/po/${i}.mo ${PREFIX}/share/locale/${i}/LC_MESSAGES/skype4pidgin.mo
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES/
+ ${INSTALL_DATA} ${WRKSRC}/po/${i}.mo ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES/skype4pidgin.mo
.endfor
.endif
diff --git a/net-im/pidgin-skype/distinfo b/net-im/pidgin-skype/distinfo
index 400cc7474740..d194119144ce 100644
--- a/net-im/pidgin-skype/distinfo
+++ b/net-im/pidgin-skype/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pidgin-skype-svn-r659.tar.xz) = fb1a5e63cd76d7dec70aa0ca9350c60b05819e13917892ee3b9bcf951519c113
-SIZE (pidgin-skype-svn-r659.tar.xz) = 125352
+SHA256 (pidgin-skype-svn-r664.tar.xz) = b784ca68628073b7640775e44258cb6bdd3a39dc9ce70598f22e9b81f3eac0ca
+SIZE (pidgin-skype-svn-r664.tar.xz) = 125564
diff --git a/net-im/pidgin-skype/pkg-plist b/net-im/pidgin-skype/pkg-plist
index 3e4e452069b8..d7ff13e9d34d 100644
--- a/net-im/pidgin-skype/pkg-plist
+++ b/net-im/pidgin-skype/pkg-plist
@@ -25,3 +25,7 @@ share/pixmaps/pidgin/emotes/skype/theme
@dirrmtry share/pixmaps/pidgin/protocols/48
@dirrmtry share/pixmaps/pidgin/protocols/22
@dirrmtry share/pixmaps/pidgin/protocols/16
+@dirrmtry share/pixmaps/pidgin/protocols
+@dirrmtry share/pixmaps/pidgin/emotes
+@dirrmtry share/pixmaps/pidgin
+@dirrmtry lib/purple-2