aboutsummaryrefslogtreecommitdiff
path: root/net-im/psi/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
commit52e8b487f6dc73b0d0baafc955c59e83ab33c41a (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /net-im/psi/Makefile
parentdbe27c5fd4471209e8b77eecbae08f3a2ad57040 (diff)
downloadports-52e8b487f6dc73b0d0baafc955c59e83ab33c41a.tar.gz
ports-52e8b487f6dc73b0d0baafc955c59e83ab33c41a.zip
Notes
Diffstat (limited to 'net-im/psi/Makefile')
-rw-r--r--net-im/psi/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index c47d1fd632d4..4b67ae4d28f2 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -30,8 +30,11 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${LOCALBASE} \
MAKE_JOBS_UNSAFE= yes
-OPTIONS= ASPELL "Use aspell for spell checking" on \
- ENCHANT "Use Enchant for spell checking" off
+OPTIONS_DEFINE= ASPELL ENCHANT
+OPTIONS_DEFAULT= ASPELL
+
+ASPELL_DESC= Use aspell for spell checking
+ENCHANT_DESC= Use Enchant for spell checking
.include <bsd.port.options.mk>
@@ -43,7 +46,7 @@ CONFIGURE_ARGS+= --release --no-separate-debug-info
PLIST_SUB+= DEBUG="@comment "
.endif
-.if defined(WITH_ASPELL)
+.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-aspell-inc=${LOCALBASE}/include \
--with-aspell-lib=${LOCALBASE}/lib
@@ -51,7 +54,7 @@ CONFIGURE_ARGS+= --with-aspell-inc=${LOCALBASE}/include \
CONFIGURE_ARGS+= --disable-aspell
.endif
-.if defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MENCHANT}
LIB_DEPENDS+= enchant.1:${PORTSDIR}/textproc/enchant
.else
CONFIGURE_ARGS+= --disable-enchant