aboutsummaryrefslogtreecommitdiff
path: root/net-im/psi
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-07-20 20:46:10 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-07-20 20:46:10 +0000
commit5936b0b76e238355d670195c64bfd0d1a59c854f (patch)
tree228b7823a2001b6b6d1537a53c98ef81816b141c /net-im/psi
parent034c7eb534bfc4527ef47b924a201d149d07f8e9 (diff)
downloadports-5936b0b76e238355d670195c64bfd0d1a59c854f.tar.gz
ports-5936b0b76e238355d670195c64bfd0d1a59c854f.zip
net-im/psi: Add patches to fix build
Add dependencies on the ui-gen target, this should fix the race condition during the build. PR: 229854 Reported by: antoine
Notes
Notes: svn path=/head/; revision=475034
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/files/patch-src_contactmanager_CMakeLists.txt9
-rw-r--r--net-im/psi/files/patch-src_sxe_CMakeLists.txt8
2 files changed, 17 insertions, 0 deletions
diff --git a/net-im/psi/files/patch-src_contactmanager_CMakeLists.txt b/net-im/psi/files/patch-src_contactmanager_CMakeLists.txt
new file mode 100644
index 000000000000..ff3f85500791
--- /dev/null
+++ b/net-im/psi/files/patch-src_contactmanager_CMakeLists.txt
@@ -0,0 +1,9 @@
+--- src/contactmanager/CMakeLists.txt.orig 2018-07-20 20:03:45 UTC
++++ src/contactmanager/CMakeLists.txt
+@@ -28,5 +28,6 @@ list(APPEND FORMS
+ qt4_wrap_ui(UI_FORMS ${FORMS})
+ qt_wrap_cpp(MOC_SOURCES ${HEADERS})
+ add_library(contactmanager STATIC ${HEADERS} ${MOC_SOURCES} ${UI_FORMS} ${PLAIN_SOURCES})
++add_dependencies(contactmanager build_ui_files)
+ target_link_libraries(contactmanager ${QT_LIBRARIES} widgets)
+ target_include_directories(contactmanager PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
diff --git a/net-im/psi/files/patch-src_sxe_CMakeLists.txt b/net-im/psi/files/patch-src_sxe_CMakeLists.txt
new file mode 100644
index 000000000000..3bb80792b8bd
--- /dev/null
+++ b/net-im/psi/files/patch-src_sxe_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- src/sxe/CMakeLists.txt.orig 2018-07-20 20:15:10 UTC
++++ src/sxe/CMakeLists.txt
+@@ -34,4 +34,5 @@ set(PLAIN_HEADERS
+
+ qt_wrap_cpp(MOC_SOURCES ${HEADERS})
+ add_library(sxe STATIC ${HEADERS} ${MOC_SOURCES} ${PLAIN_SOURCES} ${PLAIN_HEADERS})
++add_dependencies(sxe build_ui_files)
+ target_link_libraries(sxe ${QT_LIBRARIES} ${iris_LIB} libpsi_tools widgets)