aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-skype4py
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-06-21 20:33:23 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-06-21 20:33:23 +0000
commitd7aa7dad53394ef523c648e157aff560fdb1a5b9 (patch)
tree4e26817cf3e97e09f79243243ae048ea17d9170a /net-im/py-skype4py
parent9c58fe8c93f3a7c5f625d19e90ca9ddd2cdfe194 (diff)
downloadports-d7aa7dad53394ef523c648e157aff560fdb1a5b9.tar.gz
ports-d7aa7dad53394ef523c648e157aff560fdb1a5b9.zip
- Remove easy_install dependency
- Fix file removal, so that recording the plist works properly with distutils - Bump PORTREVISION to enforce a cleanup for the easy_install references With hat: python@ Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=358741
Diffstat (limited to 'net-im/py-skype4py')
-rw-r--r--net-im/py-skype4py/Makefile9
-rw-r--r--net-im/py-skype4py/files/patch-setup.py26
2 files changed, 30 insertions, 5 deletions
diff --git a/net-im/py-skype4py/Makefile b/net-im/py-skype4py/Makefile
index f76967f954d7..de1de91c479b 100644
--- a/net-im/py-skype4py/Makefile
+++ b/net-im/py-skype4py/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Skype4Py
PORTVERSION= 1.0.35
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-im devel
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +11,11 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Skype (TM) API wrapper for Python
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
+USE_PYTHON= 2
+USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-
-USE_PYDISTUTILS= easy_install
-USE_PYTHON= 2
USES= zip
.include <bsd.port.mk>
diff --git a/net-im/py-skype4py/files/patch-setup.py b/net-im/py-skype4py/files/patch-setup.py
new file mode 100644
index 000000000000..d669a8a34a04
--- /dev/null
+++ b/net-im/py-skype4py/files/patch-setup.py
@@ -0,0 +1,26 @@
+--- setup.py.orig 2013-05-25 11:00:56.000000000 +0200
++++ setup.py 2014-06-21 22:27:11.000000000 +0200
+@@ -129,11 +129,21 @@
+ print >>sys.stderr, 'epydoc not installed, skipping build_doc.'
+
+
+-commands = {'build_doc': build_doc,
+- 'install_lib': install_lib}
++commands = {'build_doc': build_doc}
+
+ desc = open("README.rst").read() + "\n" + open("CHANGES.rst").read()
+
++if sys.platform[:3] == 'win':
++ platform = 'windows'
++elif sys.platform == 'darwin':
++ platform = 'darwin'
++else:
++ platform = 'posix'
++path = os.path.join('Skype4Py', 'api')
++for name in os.listdir(path):
++ if not (name.startswith('__') or name.startswith(platform)):
++ os.remove(os.path.join(path, name))
++
+ # start the distutils setup
+ setup(name='Skype4Py',
+ version=VERSION,