aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-unmessage/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-09-15 11:59:49 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-09-15 11:59:49 +0000
commit97b928b5aaff92679caf55eb157131838b8d9e33 (patch)
tree4d17788d21f9a69c4115be7d235288257a7868fe /net-im/py-unmessage/Makefile
parent1b75711e411bb90a897e7b917ab8ae41f67951f5 (diff)
downloadports-97b928b5aaff92679caf55eb157131838b8d9e33.tar.gz
ports-97b928b5aaff92679caf55eb157131838b8d9e33.zip
Notes
Diffstat (limited to 'net-im/py-unmessage/Makefile')
-rw-r--r--net-im/py-unmessage/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-im/py-unmessage/Makefile b/net-im/py-unmessage/Makefile
index 0f7b0bb13baa..688384be9fb0 100644
--- a/net-im/py-unmessage/Makefile
+++ b/net-im/py-unmessage/Makefile
@@ -3,6 +3,7 @@
PORTNAME= unmessage
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= net-im net-p2p python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,10 +21,16 @@ RUN_DEPENDS= tor:security/tor \
${PYTHON_PKGNAMEPREFIX}pynacl>=1.0.1:security/py-pynacl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyperclip>=1.5.27:devel/py-pyperclip@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=16.6.0:devel/py-twisted@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}txtorcon>=0.19.0:security/py-txtorcon@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}txtorcon>=0.19.0:security/py-txtorcon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+# Twisted[tls]
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=0.6:dns/py-idna@${PY_FLAVOR}
USES= python:2.7
USE_PYTHON= distutils autoplist
+
NO_ARCH= yes
.include <bsd.port.mk>