aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-xmpppy-irc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 16:41:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 16:41:57 +0000
commitdd3d7f0f6c285b455f9f0f078e45879428d6426a (patch)
treea3cd2d1cd0f4a71e5f4922b4e4a665c31b7709ca /net-im/py-xmpppy-irc
parent56e56b16e70223069c6cf003a0493e808b2d5bea (diff)
downloadports-dd3d7f0f6c285b455f9f0f078e45879428d6426a.tar.gz
ports-dd3d7f0f6c285b455f9f0f078e45879428d6426a.zip
Notes
Diffstat (limited to 'net-im/py-xmpppy-irc')
-rw-r--r--net-im/py-xmpppy-irc/Makefile51
-rw-r--r--net-im/py-xmpppy-irc/distinfo3
-rw-r--r--net-im/py-xmpppy-irc/files/xmpppyirc.in19
-rw-r--r--net-im/py-xmpppy-irc/pkg-descr5
4 files changed, 78 insertions, 0 deletions
diff --git a/net-im/py-xmpppy-irc/Makefile b/net-im/py-xmpppy-irc/Makefile
new file mode 100644
index 000000000000..831edccf33d5
--- /dev/null
+++ b/net-im/py-xmpppy-irc/Makefile
@@ -0,0 +1,51 @@
+# Ports collection makefile for: py-irc-transport
+# Date created: 21 April 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmpppy-irc
+PORTVERSION= 0.3
+CATEGORIES= net-im python irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmpppy
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= irc-transport-${PORTVERSION}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= An xmpp to irc transport
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xmpp/__init__.py:${PORTSDIR}/net-im/py-xmpppy \
+ ${PYTHON_SITELIBDIR}/irclib.py:${PORTSDIR}/irc/py-irclib
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+FILES= irc.py jep0106.py jep0133.py test_jep0106.py
+PFILES= ${FILES:S.^.%%PYTHON_SITELIBDIR%%/xmpp/irc/.}
+PLIST_FILES= ${PFILES} ${PFILES:S.$.c.} ${PFILES:S.$.o.} etc/${PORTNAME:S.-..}.conf.sample
+PLIST_DIRS= %%PYTHON_SITELIBDIR%%/xmpp/irc
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD} FEXEC=${PYTHON_SITELIBDIR}/xmpp/irc/irc.py
+USE_RC_SUBR= xmpppyirc
+PORTDOCS= ChangeLog IRC-Transport-Howtouse.html README.txt
+DDIR= ${PYTHON_SITELIBDIR}/xmpp/irc
+
+post-patch:
+ @${GREP} -lr '/usr/bin/python' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e "s./usr/bin/python.${PYTHON_CMD}." \
+ -e "s!/etc/jabber/jabber-irc.conf!${PREFIX}/etc/${PORTNAME:S.-..}.conf!"
+
+do-install:
+ @${INSTALL} -d ${DDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/irc.py ${DDIR}/
+ @${INSTALL_DATA} ${FILES:M*jep*:S.^.${WRKSRC}/.} ${DDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/transport.ini ${PREFIX}/etc/${PORTNAME:S.-..}.conf.sample
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DDIR}
+ @${CHMOD} -R a-w ${DDIR}
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL} ${PORTDOCS:S.^.${WRKSRC}/.} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-im/py-xmpppy-irc/distinfo b/net-im/py-xmpppy-irc/distinfo
new file mode 100644
index 000000000000..185ce0474b8b
--- /dev/null
+++ b/net-im/py-xmpppy-irc/distinfo
@@ -0,0 +1,3 @@
+MD5 (irc-transport-0.3.tar.gz) = 8ad0190f1b158ef5990290a16eaf8084
+SHA256 (irc-transport-0.3.tar.gz) = 8dc4de9ca0f1445ed9023ee76e64de454f32c7e880f9ac37600fb1f81d2c46a4
+SIZE (irc-transport-0.3.tar.gz) = 22752
diff --git a/net-im/py-xmpppy-irc/files/xmpppyirc.in b/net-im/py-xmpppy-irc/files/xmpppyirc.in
new file mode 100644
index 000000000000..ca3df5e48bd8
--- /dev/null
+++ b/net-im/py-xmpppy-irc/files/xmpppyirc.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# PROVIDE: xmpppyirc
+# REQUIRE: DAEMON
+
+. %%RC_SUBR%%
+
+name="xmpppyirc"
+pidfile="/var/run/$name.pid"
+
+command="%%FEXEC%%"
+command_args="&"
+command_interpreter="%%PYTHON_CMD%%"
+required_files="%%PREFIX%%/etc/$name.conf"
+start_precmd="touch $pidfile && export PID=$pidfile"
+
+load_rc_config $name
+: ${xmpppyirc_enable="NO"}
+run_rc_command "$1"
diff --git a/net-im/py-xmpppy-irc/pkg-descr b/net-im/py-xmpppy-irc/pkg-descr
new file mode 100644
index 000000000000..7611165bf48b
--- /dev/null
+++ b/net-im/py-xmpppy-irc/pkg-descr
@@ -0,0 +1,5 @@
+The IRC transport is a dynamic gateway that allows XMPP/Jabber
+users to connect to IRC using their Groupchat and MUC clients.
+It is based on xmpppy and irclib Python libraries.
+
+WWW: http://xmpppy.sourceforge.net/irc/