aboutsummaryrefslogtreecommitdiff
path: root/net-im/qTox
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-10-29 18:31:11 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-10-29 18:31:11 +0000
commit285e10efd920c33f7c53b250da2cb9e046ff4f43 (patch)
tree52f6df8947c6ce9616a365ce972aa58443ce77c5 /net-im/qTox
parent2f85ce3e17a77e0f988e62a194a1cf7cd23b00bf (diff)
downloadports-285e10efd920c33f7c53b250da2cb9e046ff4f43.tar.gz
ports-285e10efd920c33f7c53b250da2cb9e046ff4f43.zip
Notes
Diffstat (limited to 'net-im/qTox')
-rw-r--r--net-im/qTox/Makefile12
-rw-r--r--net-im/qTox/distinfo4
-rw-r--r--net-im/qTox/files/patch-emoticonswidget.cpp12
-rw-r--r--net-im/qTox/files/patch-qtox.pro12
4 files changed, 16 insertions, 24 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index 286be2940afe..9ca63ebb5233 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 0.141018
+PORTVERSION= 0.141028
CATEGORIES= net-im
MAINTAINER= yuri@rawbw.com
@@ -16,16 +16,20 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tux3
+GH_COMMIT= 8ff3d1d
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= bf35c5e
-USE_QT5= core gui network opengl xml widgets buildtools_build
-USES= compiler:c++11-lib openal:soft qmake
+USE_QT5= core gui network xml opengl sql widgets buildtools_build
+USES= compiler:c++11-lib desktop-file-utils openal:soft qmake
PLIST_FILES= bin/qtox \
share/applications/qTox.desktop \
share/pixmaps/qtox.png
+post-patch:
+ ${REINPLACE_CMD} -e 's|$$$$system(git rev-parse HEAD)|"${GH_COMMIT}"|' \
+ ${WRKSRC}/qtox.pro
+
pre-configure:
${CP} ${WRKSRC}/img/icon.png ${WRKSRC}/img/qtox.png
${REINPLACE_CMD} '/Comment/s,=.*,=${COMMENT},' \
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index eabf3f5ff87e..d5d3a91f4761 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qTox-0.141018.tar.gz) = a05fd310551f3c3f09f23d463990d7727cf345f0f148f1ae359a17f1a0fa204d
-SIZE (qTox-0.141018.tar.gz) = 2588328
+SHA256 (qTox-0.141028.tar.gz) = 812d7321c8e34edde49043aab029213670e77db801abc69551f977a47bf3169b
+SIZE (qTox-0.141028.tar.gz) = 2668590
diff --git a/net-im/qTox/files/patch-emoticonswidget.cpp b/net-im/qTox/files/patch-emoticonswidget.cpp
deleted file mode 100644
index 15d3ef711ed7..000000000000
--- a/net-im/qTox/files/patch-emoticonswidget.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/widget/emoticonswidget.cpp
-+++ src/widget/emoticonswidget.cpp
-@@ -25,6 +25,8 @@
- #include <QGridLayout>
- #include <QMouseEvent>
-
-+#include <math.h>
-+
- EmoticonsWidget::EmoticonsWidget(QWidget *parent) :
- QMenu(parent)
- {
-
diff --git a/net-im/qTox/files/patch-qtox.pro b/net-im/qTox/files/patch-qtox.pro
index fbc375f229dd..06f310c8121f 100644
--- a/net-im/qTox/files/patch-qtox.pro
+++ b/net-im/qTox/files/patch-qtox.pro
@@ -1,9 +1,9 @@
---- qtox.pro.orig 2014-10-18 16:44:41 UTC
-+++ qtox.pro
-@@ -186,3 +186,15 @@
- src/cameraworker.cpp \
- src/widget/videosurface.cpp \
- src/netvideosource.cpp
+--- qtox.pro.orig 2014-10-28 21:27:51.000000000 +0100
++++ qtox.pro 2014-10-29 19:21:51.000000000 +0100
+@@ -213,3 +213,15 @@
+ src/video/netvideosource.cpp \
+ src/widget/form/tabcompleter.cpp \
+ src/video/videoframe.cpp
+
+unix {
+ target.path = $$PREFIX/bin