aboutsummaryrefslogtreecommitdiff
path: root/net-im/qTox
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-31 07:00:10 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-31 07:00:10 +0000
commit890392b62d0699405df9ee15f43c952be825e3f9 (patch)
tree1f59405947a8d708fa58f505ee8862750aba9755 /net-im/qTox
parent93273fcdf5a2242a0ffdd664e945cf47d2ab0b7b (diff)
downloadports-890392b62d0699405df9ee15f43c952be825e3f9.tar.gz
ports-890392b62d0699405df9ee15f43c952be825e3f9.zip
Notes
Diffstat (limited to 'net-im/qTox')
-rw-r--r--net-im/qTox/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index cacf2dff318d..528dfd913f91 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -24,8 +24,6 @@ LIB_DEPENDS= libtoxcore.so:net-im/tox \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-BROKEN_FreeBSD_9_i386= does not build
-
USE_GITHUB= yes
GH_ACCOUNT= tux3
@@ -47,6 +45,13 @@ PLIST_FILES= bin/qtox \
PLIST_FILES+= share/icons/hicolor/${SZ}/apps/qtox.png
.endfor
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == "gcc" && ${ARCH} == i386 && !${CFLAGS:M-march=*}
+# Needed for __atomic_fetch_add_8
+CFLAGS+= -march=i586
+.endif
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "Warning: qTox won't build if the option NaCl was selected for Tox!"
@@ -75,4 +80,4 @@ post-install:
${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>