aboutsummaryrefslogtreecommitdiff
path: root/net-im/qTox
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-08-15 14:02:23 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-08-15 14:02:23 +0000
commit4d474b6365fae19bbaca02010538e64ad041b77c (patch)
treeee82325469f61fcdc6374ae895b03b577b5b1ecb /net-im/qTox
parent927ab04c54aa2010d971c864b55134ec45dda9d1 (diff)
downloadports-4d474b6365fae19bbaca02010538e64ad041b77c.tar.gz
ports-4d474b6365fae19bbaca02010538e64ad041b77c.zip
Notes
Diffstat (limited to 'net-im/qTox')
-rw-r--r--net-im/qTox/Makefile6
-rw-r--r--net-im/qTox/distinfo5
-rw-r--r--net-im/qTox/files/patch-qtox.pro17
-rw-r--r--net-im/qTox/files/patch-src_main.cpp4
-rw-r--r--net-im/qTox/files/patch-src_platform_camera_v4l2.h2
-rw-r--r--net-im/qTox/files/patch-src_video_cameradevice.cpp39
-rw-r--r--net-im/qTox/files/patch-src_video_videomode.cpp10
-rw-r--r--net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui4
8 files changed, 52 insertions, 35 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index b7ab0520178b..2589b43b1363 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@rawbw.com
@@ -70,7 +69,8 @@ post-install:
@${GZIP_CMD} ${GZIP} < ${WRKSRC}/img/icons/qtox.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/qtox.svgz
.for SZ in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps
- @${CP} ${WRKSRC}/img/icons/${SZ}/qtox.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
+ ${INSTALL_DATA} ${WRKSRC}/img/icons/${SZ}/qtox.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
.endfor
.include <bsd.port.mk>
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index 64d17ba41329..784d8093be41 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tux3-qTox-v1.4.1_GH0.tar.gz) = 752e5efdde5e0dfb66d9f5cd0660eb989b41bd4fcfcd3a1e607bee8bde496c84
-SIZE (tux3-qTox-v1.4.1_GH0.tar.gz) = 3021986
+TIMESTAMP = 1470843999
+SHA256 (tux3-qTox-v1.5.1_GH0.tar.gz) = 5b2ee896dfe33db29f7a2775faadb9e1063a4520893333fe0c93949e06ab2578
+SIZE (tux3-qTox-v1.5.1_GH0.tar.gz) = 3452448
diff --git a/net-im/qTox/files/patch-qtox.pro b/net-im/qTox/files/patch-qtox.pro
index ef6509748c43..d8418166ae97 100644
--- a/net-im/qTox/files/patch-qtox.pro
+++ b/net-im/qTox/files/patch-qtox.pro
@@ -1,6 +1,6 @@
---- qtox.pro.orig 2016-04-24 12:44:18 UTC
+--- qtox.pro.orig 2016-08-09 23:12:33 UTC
+++ qtox.pro
-@@ -49,11 +49,11 @@ include(translations/i18n.pri)
+@@ -48,11 +48,11 @@ include(translations/i18n.pri)
system($$fromfile(translations/i18n.pri, updateallqm))
isEmpty(GIT_VERSION) {
@@ -14,10 +14,11 @@
}
DEFINES += GIT_DESCRIBE=\"\\\"$$quote($$GIT_DESCRIBE)\\\"\"
# date works on linux/mac, but it would hangs qmake on windows
-@@ -485,6 +485,18 @@ SOURCES += \
- src/persistence/history.cpp \
- src/widget/form/groupinviteform.cpp
-
+@@ -481,3 +481,15 @@ SOURCES += \
+ src/widget/tool/profileimporter.cpp \
+ src/widget/passwordedit.cpp \
+ src/video/videomode.cpp
++
+unix {
+ target.path = $$PREFIX/bin
+
@@ -29,7 +30,3 @@
+
+ INSTALLS = target desktop icon
+}
-+
- HEADERS += \
- src/audio/audio.h \
- src/core/core.h \
diff --git a/net-im/qTox/files/patch-src_main.cpp b/net-im/qTox/files/patch-src_main.cpp
index 21b36602fcb0..2de45942f99c 100644
--- a/net-im/qTox/files/patch-src_main.cpp
+++ b/net-im/qTox/files/patch-src_main.cpp
@@ -1,6 +1,6 @@
---- src/main.cpp.orig 2016-04-24 12:44:18 UTC
+--- src/main.cpp.orig 2016-08-09 23:12:33 UTC
+++ src/main.cpp
-@@ -303,3 +303,10 @@ int main(int argc, char *argv[])
+@@ -306,3 +306,10 @@ int main(int argc, char *argv[])
#endif
return errorcode;
}
diff --git a/net-im/qTox/files/patch-src_platform_camera_v4l2.h b/net-im/qTox/files/patch-src_platform_camera_v4l2.h
index 6da51cd5314f..58688e7c4a74 100644
--- a/net-im/qTox/files/patch-src_platform_camera_v4l2.h
+++ b/net-im/qTox/files/patch-src_platform_camera_v4l2.h
@@ -1,4 +1,4 @@
---- src/platform/camera/v4l2.h.orig 2016-04-24 12:44:18 UTC
+--- src/platform/camera/v4l2.h.orig 2016-08-09 23:12:33 UTC
+++ src/platform/camera/v4l2.h
@@ -24,7 +24,7 @@
#include <QPair>
diff --git a/net-im/qTox/files/patch-src_video_cameradevice.cpp b/net-im/qTox/files/patch-src_video_cameradevice.cpp
index 373bdd00422e..523f22b476af 100644
--- a/net-im/qTox/files/patch-src_video_cameradevice.cpp
+++ b/net-im/qTox/files/patch-src_video_cameradevice.cpp
@@ -1,4 +1,4 @@
---- src/video/cameradevice.cpp.orig 2016-04-24 12:44:18 UTC
+--- src/video/cameradevice.cpp.orig 2016-08-09 23:12:33 UTC
+++ src/video/cameradevice.cpp
@@ -31,7 +31,7 @@ extern "C" {
#ifdef Q_OS_WIN
@@ -9,7 +9,7 @@
#include "src/platform/camera/v4l2.h"
#endif
#ifdef Q_OS_OSX
-@@ -122,7 +122,7 @@ CameraDevice* CameraDevice::open(QString
+@@ -150,7 +150,7 @@ CameraDevice* CameraDevice::open(QString
AVDictionary* options = nullptr;
if (!iformat);
@@ -18,16 +18,7 @@
else if (devName.startsWith("x11grab#"))
{
QSize screen;
-@@ -168,7 +168,7 @@ CameraDevice* CameraDevice::open(QString
- av_dict_set(&options, "framerate", QString().setNum(mode.FPS).toStdString().c_str(), 0);
- }
- #endif
--#ifdef Q_OS_LINUX
-+#ifdef Q_OS_UNIX
- else if (iformat->name == QString("video4linux2,v4l2") && mode)
- {
- av_dict_set(&options, "video_size", QString("%1x%2").arg(mode.width).arg(mode.height).toStdString().c_str(), 0);
-@@ -311,7 +311,7 @@ QVector<QPair<QString, QString>> CameraD
+@@ -359,7 +359,7 @@ QVector<QPair<QString, QString>> CameraD
else if (iformat->name == QString("dshow"))
devices += DirectShow::getDeviceList();
#endif
@@ -36,7 +27,7 @@
else if (iformat->name == QString("video4linux2,v4l2"))
devices += v4l2::getDeviceList();
#endif
-@@ -358,7 +358,7 @@ QVector<VideoMode> CameraDevice::getVide
+@@ -461,7 +461,7 @@ QVector<VideoMode> CameraDevice::getVide
else if (iformat->name == QString("dshow"))
return DirectShow::getDeviceModes(devName);
#endif
@@ -45,7 +36,25 @@
else if (iformat->name == QString("video4linux2,v4l2"))
return v4l2::getDeviceModes(devName);
#endif
-@@ -400,7 +400,7 @@ bool CameraDevice::getDefaultInputFormat
+@@ -482,7 +482,7 @@ QVector<VideoMode> CameraDevice::getVide
+ */
+ QString CameraDevice::getPixelFormatString(uint32_t pixel_format)
+ {
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ return v4l2::getPixelFormatString(pixel_format);
+ #else
+ return QString("unknown");
+@@ -498,7 +498,7 @@ false otherwise (such as if there's no p
+ */
+ bool CameraDevice::betterPixelFormat(uint32_t a, uint32_t b)
+ {
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ return v4l2::betterPixelFormat(a, b);
+ #else
+ return false;
+@@ -518,7 +518,7 @@ bool CameraDevice::getDefaultInputFormat
avdevice_register_all();
// Desktop capture input formats
@@ -54,7 +63,7 @@
idesktopFormat = av_find_input_format("x11grab");
#endif
#ifdef Q_OS_WIN
-@@ -408,7 +408,7 @@ bool CameraDevice::getDefaultInputFormat
+@@ -526,7 +526,7 @@ bool CameraDevice::getDefaultInputFormat
#endif
// Webcam input formats
diff --git a/net-im/qTox/files/patch-src_video_videomode.cpp b/net-im/qTox/files/patch-src_video_videomode.cpp
new file mode 100644
index 000000000000..82de2be6b19d
--- /dev/null
+++ b/net-im/qTox/files/patch-src_video_videomode.cpp
@@ -0,0 +1,10 @@
+--- src/video/videomode.cpp.orig 2016-08-10 16:00:51 UTC
++++ src/video/videomode.cpp
+@@ -18,6 +18,7 @@
+ */
+
+ #include "videomode.h"
++#include <stdlib.h>
+
+ /**
+ @struct VideoMode
diff --git a/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui b/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui
index ecd791433d93..16ad32964556 100644
--- a/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui
+++ b/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui
@@ -1,8 +1,8 @@
---- src/widget/form/settings/aboutsettings.ui.orig 2016-04-25 21:28:44 UTC
+--- src/widget/form/settings/aboutsettings.ui.orig 2016-08-09 23:12:33 UTC
+++ src/widget/form/settings/aboutsettings.ui
@@ -111,6 +111,9 @@
<property name="text">
- <string>Commit hash: &lt;a href=&quot;https://github.com/tux3/qTox/commit/$GIT_VERSION&quot;&gt;$GIT_VERSION&lt;/a&gt;</string>
+ <string>Commit hash: &lt;a href=&quot;https://github.com/qTox/qTox/commit/$GIT_VERSION&quot;&gt;$GIT_VERSION&lt;/a&gt;</string>
</property>
+ <property name="visible">
+ <bool>false</bool>