aboutsummaryrefslogtreecommitdiff
path: root/net-im/qutim/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-06-16 18:44:15 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-06-16 18:44:15 +0000
commit671f9feb901b076783a4d3e2a95ed6d65b2d3357 (patch)
tree401d6abf0dd84ab105dd185672f93a3ad1094b09 /net-im/qutim/Makefile
parent9653cbbe3cb6b7b60e60d5b06299805d829ce700 (diff)
Notes
Diffstat (limited to 'net-im/qutim/Makefile')
-rw-r--r--net-im/qutim/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/qutim/Makefile b/net-im/qutim/Makefile
new file mode 100644
index 000000000000..717a3db514d1
--- /dev/null
+++ b/net-im/qutim/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: qutim
+# Date created: Mon Jun 16 20:42:11 MSD 2008
+# Whom: webmaster@kibab.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= qutim
+PORTVERSION= 0.1
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= qutIM-${PORTVERSION}
+
+MAINTAINER= webmaster@kibab.com
+COMMENT= A Qt4-based lightweight ICQ client with advanced features
+
+WRKSRC= ${WRKDIR}/qutIM
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui network xml moc_build qmake_build rcc_build uic_build
+
+PLIST_FILES= bin/qutIM
+
+pre-build:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o Makefile qutIM.pro
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/qutIM ${PREFIX}/bin
+
+.include <bsd.port.mk>