aboutsummaryrefslogtreecommitdiff
path: root/net-im/rubygem-xmpp4r/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-20 23:49:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-20 23:49:42 +0000
commitbd83fb60aa3dfcf6d5492d89756dc0bc572cc60b (patch)
treeeb88770cf85b49a369f6eaff411fb72c08e6c071 /net-im/rubygem-xmpp4r/Makefile
parent1156d3a4dc830a2f28c0ea073b658de2ca5a045b (diff)
downloadports-bd83fb60aa3dfcf6d5492d89756dc0bc572cc60b.tar.gz
ports-bd83fb60aa3dfcf6d5492d89756dc0bc572cc60b.zip
Notes
Diffstat (limited to 'net-im/rubygem-xmpp4r/Makefile')
-rw-r--r--net-im/rubygem-xmpp4r/Makefile42
1 files changed, 6 insertions, 36 deletions
diff --git a/net-im/rubygem-xmpp4r/Makefile b/net-im/rubygem-xmpp4r/Makefile
index b299962990ed..11fe9606d931 100644
--- a/net-im/rubygem-xmpp4r/Makefile
+++ b/net-im/rubygem-xmpp4r/Makefile
@@ -6,45 +6,15 @@
#
PORTNAME= xmpp4r
-PORTVERSION= 0.3.2
+PORTVERSION= 0.4
CATEGORIES= net-im ruby
-MASTER_SITES= http://download.gna.org/xmpp4r/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= ruby
+MASTER_SITES= RF/xmpp4r
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= miwi@FreeBSD.org
COMMENT= XMPP/Jabber library for Ruby
-USE_RUBY= YES
-USE_RUBY_RDOC= YES
-
-LIB_FILES= lib/xmpp4r.rb lib/xmpp4r/callbacks.rb lib/xmpp4r
-DOCS= ChangeLog LICENSE README UPDATING
-EXAMPLES= basic advanced
-
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${BUILD_WRKSRC}; ${RUBY_RDOC} \
- -o rdoc \
- --all --fileboxes --inline-source --line-numbers \
- ${LIB_FILES}
-.endif
-
-do-install:
- cd ${INSTALL_WRKSRC}; ${CP} -R ${LIB_FILES} ${RUBY_SITELIBDIR}/
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
- ${CP} -R ${WRKSRC}/rdoc/ ${RUBY_MODDOCDIR}/rdoc
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES}
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/${f}/
- ${CP} -R ${WRKSRC}/data/doc/xmpp4r/examples/${f}/ ${RUBY_MODEXAMPLESDIR}/${f}/
-.endfor
-.endif
+USE_RUBY= YES
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>