aboutsummaryrefslogtreecommitdiff
path: root/net-im/sim-im/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2006-07-14 23:27:26 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2006-07-14 23:27:26 +0000
commit9d1242333289b6a620882c3493ac38a7b40ab2ae (patch)
tree619c4f34acda4e9ac072b8794407a9008bd687f4 /net-im/sim-im/Makefile
parent10dea8ef68438248165c3be576b1cd6e63ccd093 (diff)
downloadports-9d1242333289b6a620882c3493ac38a7b40ab2ae.tar.gz
ports-9d1242333289b6a620882c3493ac38a7b40ab2ae.zip
Notes
Diffstat (limited to 'net-im/sim-im/Makefile')
-rw-r--r--net-im/sim-im/Makefile37
1 files changed, 14 insertions, 23 deletions
diff --git a/net-im/sim-im/Makefile b/net-im/sim-im/Makefile
index c3dacdfcf3e1..bb7809dacd40 100644
--- a/net-im/sim-im/Makefile
+++ b/net-im/sim-im/Makefile
@@ -1,39 +1,36 @@
-# New Ports Collection Makefile for: sim-icq
+# New Ports Collection Makefile for: sim-im
# Date created: 4 Nov 2002
# Whom: Josef El-Rayes <j.el-rayes@daemon.li>
#
# $FreeBSD$
-PORTNAME= simicq
-PORTVERSION= 0.9.3
-PORTREVISION= 5
+PORTNAME= sim-im
+PORTVERSION= 0.9.4
CATEGORIES= net-im kde
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
-DISTNAME= ${PORTNAME:S/icq//}-${PORTVERSION}-2
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME:S/-im//}-${PORTVERSION}
MAINTAINER= markus@FreeBSD.org
COMMENT= Plugin-based instant messenger
LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-2//}
+CONFLICTS= simicq-[0-9]* sim-im-devel-[0-9]*
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_QT_VER= 3
USE_PERL5_BUILD=yes
USE_AUTOTOOLS= libtool:15
+USE_OPENSSL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-PLIST_SUB+= SSL=""
-.else
-CONFIGURE_ARGS+=--disable-openssl
-PLIST_SUB+= SSL="@comment "
-.endif
-
.if defined(WITHOUT_KDE)
CONFIGURE_ARGS+=--disable-kde --enable-mt
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
@@ -46,20 +43,14 @@ PLIST_SUB+= KDE="" \
.endif
pre-everything::
-.if !defined(WITHOUT_SSL)
- @${ECHO_MSG} "You can disable SSL support by defining WITHOUT_SSL."
-.endif
.if !defined(WITHOUT_KDE)
@${ECHO_MSG} "You can disable KDE support by defining WITHOUT_KDE."
.endif
post-patch:
+.if defined(WITHOUT_KDE)
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
${CONFIGURE_WRKSRC}/configure
-
-post-configure:
-.if defined(WITHOUT_SSL)
- @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
.endif
.include <bsd.port.mk>