aboutsummaryrefslogtreecommitdiff
path: root/net-im/skype/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-05-14 04:51:34 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-05-14 04:51:34 +0000
commite604f2965ae98e00578c880f979febf4e4174364 (patch)
treeb0307bc603d2830d5dd70f760e17b8aca78bd304 /net-im/skype/Makefile
parent5289cefbd45b399346cbec0af9c592f5ffaf12fc (diff)
Create ${PREFIX}/${SKYPEDIR} before doing ${COPYTREE_SHARE}.
Without this step installing the port at 7.x has the effect: ----- % ls -ld /usr/local/share/skype drwx------ 6 root wheel 512 12 May 12:20 /usr/local/share/skype % skype /usr/local/bin/skype: /usr/local/share/skype/skype: Permission denied ----- FreeBSD 8.x is not affected since it uses BSD cpio (at ${COPYTREE_SHARE}) which behaves as expected. Note: packages are not affected, no PORTREVISION bump. PR: ports/134471 Submitted by: bsam (me) Approved by: miwi (co-maintainer, by e-mail)
Notes
Notes: svn path=/head/; revision=233869
Diffstat (limited to 'net-im/skype/Makefile')
-rw-r--r--net-im/skype/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index 15068d6ac156..29a44a3d6a07 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -61,7 +61,7 @@ do-install:
@${INSTALL} -d ${PREFIX}/share/applications
@${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
@${INSTALL_DATA} ${WRKSRC}/icons/SkypeBlue_48x48.png ${PREFIX}/share/pixmaps/skype.png
- @cd ${WRKSRC}/&&${COPYTREE_SHARE} "avatars icons sounds lang" ${PREFIX}/${SKYPEDIR}/
+ @cd ${WRKSRC}/ && {MKDIR} ${PREFIX}/${SKYPEDIR} && ${COPYTREE_SHARE} "avatars icons sounds lang" ${PREFIX}/${SKYPEDIR}/
# The binary main program
@${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/${SKYPEDIR}/