aboutsummaryrefslogtreecommitdiff
path: root/net-im/skype/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-10-29 19:36:50 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-10-29 19:36:50 +0000
commit1ae16c50ffe4c2d1fbb719e16744c9959a06bc2a (patch)
tree5ec37bca12f272ed5a2aa79bab9c2cd66d0154e4 /net-im/skype/Makefile
parent9652d8e2fed1d8feb04fc2bc485855cdd658a1f0 (diff)
downloadports-1ae16c50ffe4c2d1fbb719e16744c9959a06bc2a.tar.gz
ports-1ae16c50ffe4c2d1fbb719e16744c9959a06bc2a.zip
Notes
Diffstat (limited to 'net-im/skype/Makefile')
-rw-r--r--net-im/skype/Makefile59
1 files changed, 23 insertions, 36 deletions
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index 2e22e7421245..9c860c623027 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -6,55 +6,42 @@
#
PORTNAME= skype
-PORTVERSION= 1.2.0.18
-PORTREVISION= 4
+PORTVERSION= 1.4.0.118
CATEGORIES= net
-MASTER_SITES= NETBSD
-DISTNAME= skype_staticQT-${PORTVERSION}
+MASTER_SITES= http://download.skype.com/linux/
+DISTNAME= skype_static-${DISTVERSION}-oss
MAINTAINER= beech@FreeBSD.org
COMMENT= P2P VoIP software
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20
-USE_BZIP2= yes
-USE_LINUX= yes
-USE_X_PREFIX= yes
-ONLY_FOR_ARCHS= i386 amd64
-
-RESTRICTED= Redistribution not allowed.
-
-OPTIONS= NVIDIA_GL "Enable Nvidia Support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_NVIDIA_GL)
+.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+USE_GL= linux
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_BZIP2= yes
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386
+
+RESTRICTED= Redistribution not allowed
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
+DATADIR= ${PREFIX}/share/${PKGBASE}
do-build:
- ${BRANDELF} -t Linux ${WRKSRC}/skype
+ @${BRANDELF} -t Linux ${WRKSRC}/skype
do-install:
- @${MKDIR} ${PREFIX}/share/applications
- @${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/skype_bin
-# ${INSTALL} ${WRKSRC}/skype-callto-handler ${PREFIX}/bin/
- @${ECHO_CMD} -e "#!/bin/sh\n\nSKYPE_RESOURCES_PATH='${DATADIR}' skype_bin \"\$$@\" 2>&1 | grep -v 'SOUND_MIXER_WRITE_IGAIN failed'" >${PREFIX}/bin/skype
+ @${INSTALL} -d ${PREFIX}/share/applications
+ @${INSTALL} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
+ @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype
@${CHMOD} a+rx ${PREFIX}/bin/skype
- @${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/icons/skype_48_32.png ${PREFIX}/share/pixmaps/skype.png
- @${INSTALL} -d ${DATADIR}/icons ${DATADIR}/lang ${DATADIR}/sound
- @${INSTALL_DATA} ${WRKSRC}/icons/* ${DATADIR}/icons/
- @${INSTALL_DATA} ${WRKSRC}/lang/*.qm ${DATADIR}/lang/
- @${INSTALL_DATA} ${WRKSRC}/sound/*.wav ${DATADIR}/sound/
- @${INSTALL_DATA} ${WRKSRC}/LICENSE ${DATADIR}/
-
-post-install:
- @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. It is fixed in 6.x. Additionally there is some further work in the sound subsystem going on which fixes some related problems. This work will not be available in 6.0-RELEASE. If you experience problems update to the most recent 6.x-RELEASE, if this does not fix your problems ask on multimedia@FreeBSD.org." | fmt
-
-.include <bsd.port.post.mk>
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sounds lang LICENSE README" ${DATADIR}/
+ @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. If you experience problems update to the most recent FreeBSD RELEASE, if this does not fix your problems, ask on multimedia@FreeBSD.org." | fmt
+
+.include <bsd.port.mk>