aboutsummaryrefslogtreecommitdiff
path: root/net-im/sulci
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 08:01:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 08:01:48 +0000
commitd94e12a135d549b08876c87d23f0e37097b8b67f (patch)
treea7817bf01002778a11137175e6c4653efd2e6479 /net-im/sulci
parent7f529b984e790b85f24d7cbd7a16019c2361664c (diff)
downloadports-d94e12a135d549b08876c87d23f0e37097b8b67f.tar.gz
ports-d94e12a135d549b08876c87d23f0e37097b8b67f.zip
Notes
Diffstat (limited to 'net-im/sulci')
-rw-r--r--net-im/sulci/Makefile28
-rw-r--r--net-im/sulci/files/without-muc-log.patch21
-rw-r--r--net-im/sulci/pkg-descr5
3 files changed, 42 insertions, 12 deletions
diff --git a/net-im/sulci/Makefile b/net-im/sulci/Makefile
index cd7c631daa47..ffd00430e1ba 100644
--- a/net-im/sulci/Makefile
+++ b/net-im/sulci/Makefile
@@ -15,27 +15,28 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a./-alpha-/}
MAINTAINER= dsh@vlink.ru
COMMENT= A Jabber bot
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ${LOCALBASE}/lib/ocaml/cryptokit.cma:${PORTSDIR}/security/ocaml-cryptokit \
- ${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
- ${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
- ${OCAML_SITELIBDIR}/netclient/netclient.a:${PORTSDIR}/net/ocaml-netclient \
- ${OCAML_SITELIBDIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+BUILD_DEPENDS= ${LOCALBASE}/lib/ocaml/cryptokit.cma:${PORTSDIR}/security/ocaml-cryptokit \
+ ${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex \
+ ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
+ ${LOCALBASE}/${OCAML_SITELIBDIR}/netclient/netclient.a:${PORTSDIR}/net/ocaml-netclient \
+ ${LOCALBASE}/${OCAML_SITELIBDIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2 \
pcre.0:${PORTSDIR}/devel/pcre
-RUN_DEPENDS= ${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
+RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
mueller:${PORTSDIR}/russian/mueller-dic
USE_BZIP2= yes
USE_GMAKE= yes
+USE_OCAML= yes
+NO_OCAML_RUNDEPENDS= yes
+USE_OCAML_FINDLIB= yes
USE_RC_SUBR= ${PORTNAME}.sh
ALL_TARGET= subdirs
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-OCAML_SITELIBDIR= ${LOCALBASE}/lib/ocaml/site-lib
+OPTIONS= MUC_LOG "with muc_log plugin" on
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} ${PREFIX}/sbin
@@ -70,4 +71,11 @@ do-install:
post-install:
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+.if defined(WITHOUT_MUC_LOG)
+EXTRA_PATCHES+= ${FILESDIR}/without-muc-log.patch
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/sulci/files/without-muc-log.patch b/net-im/sulci/files/without-muc-log.patch
new file mode 100644
index 000000000000..f241c39544f2
--- /dev/null
+++ b/net-im/sulci/files/without-muc-log.patch
@@ -0,0 +1,21 @@
+--- sulci/Makefile.orig Tue Feb 21 16:05:07 2006
++++ sulci/Makefile Wed Apr 26 18:11:29 2006
+@@ -5,7 +5,7 @@
+ include Makefile.conf
+
+ SOURCES = version.ml config.ml logger.ml common.ml types.ml lang.ml muc.ml \
+- find_url.ml muc_log.ml hooks.ml iq.ml http_suck.ml
++ find_url.ml hooks.ml iq.ml http_suck.ml
+
+ SUBDIRS = lang
+
+--- sulci/hooks.ml.orig Sat Feb 4 20:00:48 2006
++++ sulci/hooks.ml Wed Apr 26 18:10:59 2006
+@@ -167,7 +167,6 @@
+ in
+ (try
+ let event = get_event () in
+- Muc_log.process_log event from xml;
+ List.iter (fun proc -> proc event from xml out) !filters;
+ (match event with
+ | Iq _ ->
diff --git a/net-im/sulci/pkg-descr b/net-im/sulci/pkg-descr
index dc786dcac1e1..ffbf402f53a4 100644
--- a/net-im/sulci/pkg-descr
+++ b/net-im/sulci/pkg-descr
@@ -1,3 +1,4 @@
-Sulci, an Jabber bot.
+Sulci is a free (GPL) Jabber bot that provides functionalities for
+individuals and chatrooms.
-WWW: http://home.ermine.pp.ru/svn/ocaml/trunk/
+WWW: http://ejabberd.jabber.ru/sulci