aboutsummaryrefslogtreecommitdiff
path: root/net-im/teamwords
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-02 16:17:34 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-02 16:17:34 +0000
commitf12d2c5b853f9687475ca63a7928e753e004b3ce (patch)
treee44bfd567091ac200572ca0bb05a50dfa3c8e161 /net-im/teamwords
parent9793fdce4f0bc997730306df99a839d3877b1b56 (diff)
Notes
Diffstat (limited to 'net-im/teamwords')
-rw-r--r--net-im/teamwords/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-im/teamwords/Makefile b/net-im/teamwords/Makefile
index 5e7e3f3fd1ec..d4459750ab0c 100644
--- a/net-im/teamwords/Makefile
+++ b/net-im/teamwords/Makefile
@@ -3,8 +3,8 @@
PORTNAME= teamwords
PORTVERSION= 0.2.1
-PORTREVISION= 3
DISTVERSIONPREFIX= v
+PORTREVISION= 3
CATEGORIES= net-im
MAINTAINER= kmoore@FreeBSD.org
@@ -12,10 +12,11 @@ COMMENT= Unofficial Qt Slack client
LICENSE= LGPL3
+USES= compiler:c++11-lang qmake
USE_LDCONFIG= yes
-USE_QT5= core gui network svg linguist \
+USE_QT5= core gui widgets network svg linguist \
webkit buildtools x11extras
-USES= compiler:c++11-lang qmake tar:xz
+USE_GL= gl
QMAKE_ARGS= CONFIG+="configure"
@@ -30,7 +31,7 @@ SUB_FILES= teamwords.desktop
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/teamwords ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/${SUB_FILES} ${STAGEDIR}${PREFIX}/share/applications/
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
${INSTALL_DATA} ${WRKSRC}/images/png/Slack.png ${STAGEDIR}${PREFIX}/share/icons/teamwords.png
.include <bsd.port.mk>