aboutsummaryrefslogtreecommitdiff
path: root/net-im/telegramqml
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-09-04 16:42:33 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-09-04 16:42:33 +0000
commitc187bdaf131d4444b798b44cf7facba2bab8db26 (patch)
tree0580ac98734cd88fea36b672c17a973a1062e4c7 /net-im/telegramqml
parent2c08bca1dcc287e5ff1c8fa69ec3f04dafc18eff (diff)
downloadports-c187bdaf131d4444b798b44cf7facba2bab8db26.tar.gz
ports-c187bdaf131d4444b798b44cf7facba2bab8db26.zip
Notes
Diffstat (limited to 'net-im/telegramqml')
-rw-r--r--net-im/telegramqml/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-im/telegramqml/Makefile b/net-im/telegramqml/Makefile
index 1adcd39b9fc7..b12866f19b86 100644
--- a/net-im/telegramqml/Makefile
+++ b/net-im/telegramqml/Makefile
@@ -25,6 +25,12 @@ USE_LDCONFIG= yes
QMAKE_ARGS= BUILD_MODE+=lib \
LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae"
+# Explicitly disable C++11, as Qt 5.6 defaults to -std=gnu++11 when the
+# compiler supports it and the build currently fails.
+# ../TelegramQML-0.9.2/telegramqml.cpp:4794:10: error: case value evaluates to 2573335900, which cannot be narrowed to type 'int' [-Wc++11-narrowing]
+# case Update::typeUpdateReadHistoryInbox:
+QMAKE_ARGS+= CONFIG-="c++11"
+
post-patch:
@${REINPLACE_CMD} -e "/isEmpty(OPENSSL_INCLUDE_PATH)/d" \
${WRKSRC}/telegramqml.pri