aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-gabble
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-04-19 20:08:06 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-04-19 20:08:06 +0000
commitf1fb28cc0e6b50bb0b0f99b643771fa312d5c695 (patch)
treed90dec22db08ea28738b16d695812d7bd20f6c36 /net-im/telepathy-gabble
parent6ed2b06d80422c7d5e9a172fdd340cd7df552998 (diff)
downloadports-f1fb28cc0e6b50bb0b0f99b643771fa312d5c695.tar.gz
ports-f1fb28cc0e6b50bb0b0f99b643771fa312d5c695.zip
Notes
Diffstat (limited to 'net-im/telepathy-gabble')
-rw-r--r--net-im/telepathy-gabble/Makefile33
-rw-r--r--net-im/telepathy-gabble/distinfo3
-rw-r--r--net-im/telepathy-gabble/pkg-descr9
-rw-r--r--net-im/telepathy-gabble/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
new file mode 100644
index 000000000000..651e1afb5ab9
--- /dev/null
+++ b/net-im/telepathy-gabble/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: telepathy-gabble
+# Date created: Apr 19 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= telepathy-gabble
+PORTVERSION= 0.5.10
+CATEGORIES= net-im
+MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Jabber Connection Manager for Telepathy Framework
+
+LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
+ dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
+ telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
+ loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth
+
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_PYTHON_BUILD= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-gabble/distinfo b/net-im/telepathy-gabble/distinfo
new file mode 100644
index 000000000000..c207ebca40d8
--- /dev/null
+++ b/net-im/telepathy-gabble/distinfo
@@ -0,0 +1,3 @@
+MD5 (telepathy-gabble-0.5.10.tar.gz) = f3ad7ac1240593033299ccbf86fbc475
+SHA256 (telepathy-gabble-0.5.10.tar.gz) = 3c4eb81c9d516937565a295beb0e98ab5c2a04864a0a5c8cef32916c63056b05
+SIZE (telepathy-gabble-0.5.10.tar.gz) = 591984
diff --git a/net-im/telepathy-gabble/pkg-descr b/net-im/telepathy-gabble/pkg-descr
new file mode 100644
index 000000000000..730ea4f1c217
--- /dev/null
+++ b/net-im/telepathy-gabble/pkg-descr
@@ -0,0 +1,9 @@
+Gabble is a Jabber/XMPP connection manager for the Telepathy framework,
+currently supporting single user chats, multi user chats and voice/video
+calls. Install this package to use Telepathy instant messaging clients
+with Jabber/XMPP servers, including Google Talk.
+
+WWW: http://telepathy.freedesktop.org/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/net-im/telepathy-gabble/pkg-plist b/net-im/telepathy-gabble/pkg-plist
new file mode 100644
index 000000000000..654f1060d0dd
--- /dev/null
+++ b/net-im/telepathy-gabble/pkg-plist
@@ -0,0 +1,5 @@
+bin/telepathy-gabble
+share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.gabble.service
+share/telepathy/managers/gabble.manager
+@dirrmtry share/telepathy/managers
+@dirrmtry share/telepathy