aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-gabble
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/telepathy-gabble
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'net-im/telepathy-gabble')
-rw-r--r--net-im/telepathy-gabble/Makefile40
-rw-r--r--net-im/telepathy-gabble/distinfo4
-rw-r--r--net-im/telepathy-gabble/pkg-plist19
3 files changed, 35 insertions, 28 deletions
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index 038b3f80ee36..1f0e057bb7d2 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -1,43 +1,37 @@
-# New ports collection makefile for: telepathy-gabble
-# Date created: Apr 19 2007
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-gabble/Makefile,v 1.10 2010/11/14 16:18:09 marcus Exp $
+# $MCom: ports/net-im/telepathy-gabble/Makefile,v 1.22 2012/08/08 16:56:40 kwm Exp $
PORTNAME= telepathy-gabble
-PORTVERSION= 0.10.4
+PORTVERSION= 0.16.1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Jabber Connection Manager for Telepathy Framework
-LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
- dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
- nice.pc:${PORTSDIR}/net-im/libnice \
- uuid.pc:${PORTSDIR}/misc/e2fsprogs-libuuid \
- telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
- loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth
-
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ telepathy-glib>=0.18.0:${PORTSDIR}/net-im/telepathy-glib \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
+ nice:${PORTSDIR}/net-im/libnice \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ loudmouth-1:${PORTSDIR}/net-im/loudmouth
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-Werror
LDFLAGS+= ${PTHREAD_LIBS}
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig glib20
+USE_GNOME= gnomehack glib20
+USE_SQLITE= yes
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
+CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
MAN8= telepathy-gabble.8
-.include <bsd.port.pre.mk>
+PLIST_SUB= PVERSION=${PORTVERSION}
.if defined(WITH_OPENSSL_BASE)
CONFIGURE_ENV+= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
@@ -47,4 +41,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/lib/ext/wocky/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-gabble/distinfo b/net-im/telepathy-gabble/distinfo
index 7f77130ac4aa..3bd9465407b1 100644
--- a/net-im/telepathy-gabble/distinfo
+++ b/net-im/telepathy-gabble/distinfo
@@ -1,2 +1,2 @@
-SHA256 (telepathy-gabble-0.10.4.tar.gz) = abdf07e833b934fa7cd0c9e34894a11da037adf03a4fdde4dc7818ed990a662c
-SIZE (telepathy-gabble-0.10.4.tar.gz) = 2936168
+SHA256 (telepathy-gabble-0.16.1.tar.gz) = 77536d0ca6c040f1b1bd46c6f5914d0677a6dc6ecf1e858816c24fcf07e3f310
+SIZE (telepathy-gabble-0.16.1.tar.gz) = 2644994
diff --git a/net-im/telepathy-gabble/pkg-plist b/net-im/telepathy-gabble/pkg-plist
index 2bd653be6e31..62bf393cab5e 100644
--- a/net-im/telepathy-gabble/pkg-plist
+++ b/net-im/telepathy-gabble/pkg-plist
@@ -1,6 +1,17 @@
+bin/telepathy-gabble-xmpp-console
+lib/telepathy/gabble-0/lib/libgabble-plugins-%%PVERSION%%.so
+lib/telepathy/gabble-0/lib/libgabble-plugins.a
+lib/telepathy/gabble-0/lib/libgabble-plugins.la
+lib/telepathy/gabble-0/lib/libgabble-plugins.so
+lib/telepathy/gabble-0/lib/libwocky-telepathy-gabble-%%PVERSION%%.so
+lib/telepathy/gabble-0/lib/libwocky.a
+lib/telepathy/gabble-0/lib/libwocky.la
+lib/telepathy/gabble-0/lib/libwocky.so
+lib/telepathy/gabble-0/plugins/libconsole.la
+lib/telepathy/gabble-0/plugins/libconsole.so
+lib/telepathy/gabble-0/plugins/libgateways.la
+lib/telepathy/gabble-0/plugins/libgateways.so
libexec/telepathy-gabble
-lib/telepathy/gabble-0/gateways.la
-lib/telepathy/gabble-0/gateways.so
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.gabble.service
%%DOCSDIR%%/muc-bytestream.html
%%DOCSDIR%%/olpc.html
@@ -10,5 +21,7 @@ share/telepathy/managers/gabble.manager
@dirrmtry share/telepathy/managers
@dirrmtry share/telepathy
@dirrm %%DOCSDIR%%
-@dirrm lib/telepathy/gabble-0
+@dirrmtry lib/telepathy/gabble-0/plugins
+@dirrmtry lib/telepathy/gabble-0/lib
+@dirrmtry lib/telepathy/gabble-0
@dirrmtry lib/telepathy