aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-haze
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-01-11 11:53:23 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-01-11 11:53:23 +0000
commit1ca69edf07cbc5339a4d8d10035aeb86e07e6810 (patch)
treeb3e912335b24ed90d36917c92baf3e13b50efe68 /net-im/telepathy-haze
parent9ff46d6e36b0ec9afe77c77f31e169e3f1191987 (diff)
downloadports-1ca69edf07cbc5339a4d8d10035aeb86e07e6810.tar.gz
ports-1ca69edf07cbc5339a4d8d10035aeb86e07e6810.zip
Notes
Diffstat (limited to 'net-im/telepathy-haze')
-rw-r--r--net-im/telepathy-haze/Makefile2
-rw-r--r--net-im/telepathy-haze/files/patch-src_media-stream.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/net-im/telepathy-haze/Makefile b/net-im/telepathy-haze/Makefile
index 08eb87739db0..b4d2fbd8230f 100644
--- a/net-im/telepathy-haze/Makefile
+++ b/net-im/telepathy-haze/Makefile
@@ -1,9 +1,9 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/net-im/telepathy-haze/Makefile 19801 2014-08-13 09:46:10Z gusi $
PORTNAME= telepathy-haze
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/telepathy-haze/
diff --git a/net-im/telepathy-haze/files/patch-src_media-stream.c b/net-im/telepathy-haze/files/patch-src_media-stream.c
new file mode 100644
index 000000000000..3757d0dc0d87
--- /dev/null
+++ b/net-im/telepathy-haze/files/patch-src_media-stream.c
@@ -0,0 +1,15 @@
+This patch fixes a build with libpurple 2.0.12.
+
+http://pidgin.im/pipermail/devel/2015-March/023639.html
+Replaces the old emu with the _PASSIVE.
+--- src/media-stream.c.orig 2016-01-11 12:37:14.015586000 +0100
++++ src/media-stream.c 2016-01-11 12:39:24.449684000 +0100
+@@ -1076,7 +1076,7 @@
+ if (proto == TP_MEDIA_STREAM_BASE_PROTO_UDP)
+ protocol = PURPLE_MEDIA_NETWORK_PROTOCOL_UDP;
+ else if (proto == TP_MEDIA_STREAM_BASE_PROTO_TCP)
+- protocol = PURPLE_MEDIA_NETWORK_PROTOCOL_TCP;
++ protocol = PURPLE_MEDIA_NETWORK_PROTOCOL_TCP_PASSIVE;
+ else
+ DEBUG ("Unknown network protocol");
+