aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-salut/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-04-19 20:11:55 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-04-19 20:11:55 +0000
commit64fda164febdb568be23c7617686fdf32317df32 (patch)
tree5e4615f291b1f43df8ed3eb7d2189b4eaa8d37b7 /net-im/telepathy-salut/Makefile
parentae8f7c478fde857d6667fa27616ccc803a3f6dfa (diff)
Notes
Diffstat (limited to 'net-im/telepathy-salut/Makefile')
-rw-r--r--net-im/telepathy-salut/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
new file mode 100644
index 000000000000..349915d575ec
--- /dev/null
+++ b/net-im/telepathy-salut/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: telepathy-salut
+# Date created: Apr 16 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= telepathy-salut
+PORTVERSION= 0.1.1
+CATEGORIES= net-im
+MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Link-local Connection Manager for Telepathy Framework
+
+LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
+ dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
+ avahi-glib.pc:${PORTSDIR}/net/avahi
+
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_OPENSSL= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|make -C|${GMAKE} -C|g' \
+ ${WRKSRC}/src/Makefile.in \
+ ${WRKSRC}/tests/Makefile.in \
+ ${WRKSRC}/lib/gibber/examples/Makefile.in
+
+.include <bsd.port.mk>