aboutsummaryrefslogtreecommitdiff
path: root/net-im/tkabber-plugins-devel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-27 21:31:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-27 21:31:35 +0000
commit2528aa358bf2840905a4e451cdb6a5470d230476 (patch)
treee5595ba68e8817570dce545d10b9b3c9fec4645f /net-im/tkabber-plugins-devel/Makefile
parentfcec3afc9cea4a09136b133b3d4525e2c009e816 (diff)
downloadports-2528aa358bf2840905a4e451cdb6a5470d230476.tar.gz
ports-2528aa358bf2840905a4e451cdb6a5470d230476.zip
Notes
Diffstat (limited to 'net-im/tkabber-plugins-devel/Makefile')
-rw-r--r--net-im/tkabber-plugins-devel/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-im/tkabber-plugins-devel/Makefile b/net-im/tkabber-plugins-devel/Makefile
new file mode 100644
index 000000000000..150c23a9787c
--- /dev/null
+++ b/net-im/tkabber-plugins-devel/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: tkabber-plugins
+# Date created: Wed Oct 17 19:09:46 MSD 2007
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkabber-plugins
+PORTVERSION= 20071014
+CATEGORIES= net-im
+MASTER_SITES= http://ports.internal.vlink.ru/distfiles/
+
+MAINTAINER= dsh@vlink.ru
+COMMENT= External Plugins for Tkabber
+
+RUN_DEPENDS= tkabber-devel>=0.10.a.20071015:${PORTSDIR}/net-im/tkabber-devel
+
+USE_BZIP2= yes
+
+NO_BUILD= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUBDIRS= aniemoticons attline bc browser checkers chess ctcomp \
+ custom-urls cyrillize debug ejabberd floatinglog georoster \
+ gmail iconsets jidlink latex mute openurl osd presencecmd \
+ quiz renju reversi socials spy tclchat tkabber-khim traffic \
+ whiteboard
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${SUBDIRS}" ${DATADIR})
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for i in COPYING ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>