aboutsummaryrefslogtreecommitdiff
path: root/net-im/tmsnc
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-09-18 04:51:17 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-09-18 04:51:17 +0000
commit2889c4d38b9b3a40b91c86a8d8660c5f16237a52 (patch)
tree1d4a46312c436945e2b0eebb13139562767e7a3b /net-im/tmsnc
parent5d5f58c41f90a500c294e8416b159b72b6ba3fb6 (diff)
- add tmsnc-0.2.5
TMSNC is a textbased (console) MSN client written in C. TMSNC should work on most Unix (Linux, BSD, MacOS) compatible operating systems. The goal of this project is to create a client like MSN Messenger (with sound, webcam and file transfer support), but without any graphical features. WWW: http://tmsnc.sourceforge.net/ PR: 85951 Submitted by: Tsung-Han Yeh <snowfly@yuntech.edu.tw> Contributed by: garga
Notes
Notes: svn path=/head/; revision=143057
Diffstat (limited to 'net-im/tmsnc')
-rw-r--r--net-im/tmsnc/Makefile32
-rw-r--r--net-im/tmsnc/distinfo2
-rw-r--r--net-im/tmsnc/files/patch-configure86
-rw-r--r--net-im/tmsnc/pkg-descr11
-rw-r--r--net-im/tmsnc/pkg-plist6
5 files changed, 137 insertions, 0 deletions
diff --git a/net-im/tmsnc/Makefile b/net-im/tmsnc/Makefile
new file mode 100644
index 000000000000..b67f30867f59
--- /dev/null
+++ b/net-im/tmsnc/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tmsnc
+# Date created: 10 Sep 2005
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tmsnc
+PORTVERSION= 0.2.5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= A textbased (console) MSN client
+
+# this port need ncurses 5.4
+BUILD_DEPENDS+= ${LOCALBASE}/include/ncurses/ncurses.h:${PORTSDIR}/devel/ncurses
+RUN_DEPENDS+= ${LOCALBASE}/include/ncurses/ncurses.h:${PORTSDIR}/devel/ncurses
+
+GNU_CONFIGURE= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+MAN1= tmsnc.1
+
+.include <bsd.port.mk>
diff --git a/net-im/tmsnc/distinfo b/net-im/tmsnc/distinfo
new file mode 100644
index 000000000000..38bea6b6ac76
--- /dev/null
+++ b/net-im/tmsnc/distinfo
@@ -0,0 +1,2 @@
+MD5 (tmsnc-0.2.5.tar.gz) = 3943b017d071a6fd42835d15bb40347d
+SIZE (tmsnc-0.2.5.tar.gz) = 213481
diff --git a/net-im/tmsnc/files/patch-configure b/net-im/tmsnc/files/patch-configure
new file mode 100644
index 000000000000..893473b6e817
--- /dev/null
+++ b/net-im/tmsnc/files/patch-configure
@@ -0,0 +1,86 @@
+--- configure.orig Wed Aug 10 17:42:42 2005
++++ configure Wed Sep 14 08:29:30 2005
+@@ -6145,81 +6145,12 @@
+
+ if $search_ncurses
+ then
+- if test -f /usr/include/ncurses.h
+- then
+- echo "$as_me:$LINENO: result: Found ncurses on /usr/include/ncurses.h" >&5
+-echo "${ECHO_T}Found ncurses on /usr/include/ncurses.h" >&6
+- CURSES_LIBS="-lncurses"
+- CURSES_INCLUDEDIR=""
+- search_ncurses=false
+- screen_manager="ncurses on /usr/include"
+- cat >>confdefs.h <<\_ACEOF
+-#define HAS_CURSES 1
+-_ACEOF
+-
+- has_curses=true
+- cat >>confdefs.h <<\_ACEOF
+-#define USE_NCURSES 1
+-_ACEOF
+-
+- fi
+- fi
+-
+-
+- if $search_ncurses
+- then
+- if test -f /usr/include/ncurses/ncurses.h
+- then
+- echo "$as_me:$LINENO: result: Found ncurses on /usr/include/ncurses/ncurses.h" >&5
+-echo "${ECHO_T}Found ncurses on /usr/include/ncurses/ncurses.h" >&6
+- CURSES_LIBS="-lncurses"
+- CURSES_INCLUDEDIR="-I/usr/include/ncurses"
+- search_ncurses=false
+- screen_manager="ncurses on /usr/include/ncurses"
+- cat >>confdefs.h <<\_ACEOF
+-#define HAS_CURSES 1
+-_ACEOF
+-
+- has_curses=true
+- cat >>confdefs.h <<\_ACEOF
+-#define USE_NCURSES 1
+-_ACEOF
+-
+- fi
+- fi
+-
+-
+- if $search_ncurses
+- then
+- if test -f /usr/local/include/ncurses.h
+- then
+- echo "$as_me:$LINENO: result: Found ncurses on /usr/local/include/ncurses.h" >&5
+-echo "${ECHO_T}Found ncurses on /usr/local/include/ncurses.h" >&6
+- CURSES_LIBS="-L/usr/local/lib -lncurses"
+- CURSES_INCLUDEDIR="-I/usr/local/include"
+- search_ncurses=false
+- screen_manager="ncurses on /usr/local"
+- cat >>confdefs.h <<\_ACEOF
+-#define HAS_CURSES 1
+-_ACEOF
+-
+- has_curses=true
+- cat >>confdefs.h <<\_ACEOF
+-#define USE_NCURSES 1
+-_ACEOF
+-
+- fi
+- fi
+-
+-
+- if $search_ncurses
+- then
+ if test -f /usr/local/include/ncurses/ncurses.h
+ then
+ echo "$as_me:$LINENO: result: Found ncurses on /usr/local/include/ncurses/ncurses.h" >&5
+ echo "${ECHO_T}Found ncurses on /usr/local/include/ncurses/ncurses.h" >&6
+- CURSES_LIBS="-L/usr/local/lib -L/usr/local/lib/ncurses -lncurses"
+- CURSES_INCLUDEDIR="-I/usr/local/include/ncurses"
++ CURSES_LIBS="-L/usr/local/lib -L/usr/local/lib/ncurses -Wl,-rpath,/usr/local/lib -lncurses"
++ CURSES_INCLUDEDIR="-I/usr/local/include -I/usr/local/include/ncurses"
+ search_ncurses=false
+ screen_manager="ncurses on /usr/local/include/ncurses"
+ cat >>confdefs.h <<\_ACEOF
diff --git a/net-im/tmsnc/pkg-descr b/net-im/tmsnc/pkg-descr
new file mode 100644
index 000000000000..360347e19bee
--- /dev/null
+++ b/net-im/tmsnc/pkg-descr
@@ -0,0 +1,11 @@
+Tmsnc is a textbased (console) MSN client written in C.
+Tmsnc should work on most Unix (Linux, BSD, MacOS) compatible operating systems.
+
+The goal of this project is to create a client like MSN Messenger
+(with sound, webcam and file transfer support),
+but without any graphical features.
+
+Instead tmsnc has an interface written in NCurses,
+a library for textbased terminal interaction.
+
+WWW: http://tmsnc.sourceforge.net/
diff --git a/net-im/tmsnc/pkg-plist b/net-im/tmsnc/pkg-plist
new file mode 100644
index 000000000000..6b85068790da
--- /dev/null
+++ b/net-im/tmsnc/pkg-plist
@@ -0,0 +1,6 @@
+bin/tmsnc
+%%NLS%%share/locale/en/LC_MESSAGES/tmsnc.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tmsnc.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/tmsnc.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/tmsnc.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tmsnc.mo