aboutsummaryrefslogtreecommitdiff
path: root/net-im/tox/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-02-24 21:57:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-02-24 21:57:29 +0000
commit18d0289d459968ea28afd012df38849e476aa223 (patch)
tree655da7b520f3a73109cc42d0b6ed45433544e506 /net-im/tox/Makefile
parente42957eb1e05e9843fa8fb58e62eb60ba0bad29a (diff)
downloadports-18d0289d459968ea28afd012df38849e476aa223.tar.gz
ports-18d0289d459968ea28afd012df38849e476aa223.zip
Notes
Diffstat (limited to 'net-im/tox/Makefile')
-rw-r--r--net-im/tox/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
new file mode 100644
index 000000000000..eb384c0e7636
--- /dev/null
+++ b/net-im/tox/Makefile
@@ -0,0 +1,41 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= ProjectTox-Core
+PORTVERSION= 0.140222
+CATEGORIES= net-im net-p2p
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= ProjectTox-Core library, a decentralized and secure messenger
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= checkmk:${PORTSDIR}/devel/libcheck
+LIB_DEPENDS= libsodium.so:${PORTSDIR}/security/libsodium \
+ libvpx.so:${PORTSDIR}/multimedia/libvpx \
+ libopus.so:${PORTSDIR}/audio/opus
+
+USE_GITHUB= yes
+GH_ACCOUNT= irungentoo
+GH_PROJECT= ProjectTox-Core
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= f219fb4
+
+USE_AUTOTOOLS= automake autoconf libtoolize
+USES= pkgconfig
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= PHONE
+OPTIONS_DEFAULT=PHONE
+
+PHONE_DESC= Enable phone test
+PHONE_CONFIGURE_ENABLE= phone
+PHONE_LIB_DEPENDS= libopenal.so:${PORTSDIR}/audio/openal \
+ libv4l2.so:${PORTSDIR}/multimedia/libv4l \
+ libswscale.so:${PORTSDIR}/multimedia/ffmpeg
+PHONE_USE= SDL=sdl
+
+pre-configure:
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.mk>