aboutsummaryrefslogtreecommitdiff
path: root/net-im/tox
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-02-24 21:57:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-02-24 21:57:29 +0000
commit18d0289d459968ea28afd012df38849e476aa223 (patch)
tree655da7b520f3a73109cc42d0b6ed45433544e506 /net-im/tox
parente42957eb1e05e9843fa8fb58e62eb60ba0bad29a (diff)
downloadports-18d0289d459968ea28afd012df38849e476aa223.tar.gz
ports-18d0289d459968ea28afd012df38849e476aa223.zip
Notes
Diffstat (limited to 'net-im/tox')
-rw-r--r--net-im/tox/Makefile41
-rw-r--r--net-im/tox/distinfo2
-rw-r--r--net-im/tox/files/patch-Makefile.am11
-rw-r--r--net-im/tox/files/patch-toxav_phone.c11
-rw-r--r--net-im/tox/pkg-descr10
-rw-r--r--net-im/tox/pkg-plist13
6 files changed, 88 insertions, 0 deletions
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
new file mode 100644
index 000000000000..eb384c0e7636
--- /dev/null
+++ b/net-im/tox/Makefile
@@ -0,0 +1,41 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= ProjectTox-Core
+PORTVERSION= 0.140222
+CATEGORIES= net-im net-p2p
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= ProjectTox-Core library, a decentralized and secure messenger
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= checkmk:${PORTSDIR}/devel/libcheck
+LIB_DEPENDS= libsodium.so:${PORTSDIR}/security/libsodium \
+ libvpx.so:${PORTSDIR}/multimedia/libvpx \
+ libopus.so:${PORTSDIR}/audio/opus
+
+USE_GITHUB= yes
+GH_ACCOUNT= irungentoo
+GH_PROJECT= ProjectTox-Core
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= f219fb4
+
+USE_AUTOTOOLS= automake autoconf libtoolize
+USES= pkgconfig
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= PHONE
+OPTIONS_DEFAULT=PHONE
+
+PHONE_DESC= Enable phone test
+PHONE_CONFIGURE_ENABLE= phone
+PHONE_LIB_DEPENDS= libopenal.so:${PORTSDIR}/audio/openal \
+ libv4l2.so:${PORTSDIR}/multimedia/libv4l \
+ libswscale.so:${PORTSDIR}/multimedia/ffmpeg
+PHONE_USE= SDL=sdl
+
+pre-configure:
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/net-im/tox/distinfo b/net-im/tox/distinfo
new file mode 100644
index 000000000000..bdd62f0dc4fb
--- /dev/null
+++ b/net-im/tox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ProjectTox-Core-0.140222.tar.gz) = 7340be430a0cb66443581bfcfa6236ba1e0c485eabb15e6f528d4bce87807f93
+SIZE (ProjectTox-Core-0.140222.tar.gz) = 244242
diff --git a/net-im/tox/files/patch-Makefile.am b/net-im/tox/files/patch-Makefile.am
new file mode 100644
index 000000000000..d49d3ba81bb9
--- /dev/null
+++ b/net-im/tox/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2014-02-22 23:52:26.000000000 +0100
++++ Makefile.am 2014-02-23 17:07:16.000000000 +0100
+@@ -2,7 +2,7 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(libdir)data/pkgconfig
+ pkgconfig_DATA = $(top_builddir)/libtoxcore.pc
+
+ BUILT_SOURCES = $(top_builddir)/libtoxcore.pc
diff --git a/net-im/tox/files/patch-toxav_phone.c b/net-im/tox/files/patch-toxav_phone.c
new file mode 100644
index 000000000000..5f1b8e7a2dbc
--- /dev/null
+++ b/net-im/tox/files/patch-toxav_phone.c
@@ -0,0 +1,11 @@
+--- toxav/phone.c.orig 2014-02-22 23:52:26.000000000 +0100
++++ toxav/phone.c 2014-02-23 22:31:19.000000000 +0100
+@@ -67,7 +67,7 @@
+ /* the quit event for SDL */
+ #define FF_QUIT_EVENT (SDL_USEREVENT + 2)
+
+-#ifdef __linux__
++#if defined( __linux__) || defined(__FreeBSD__)
+ #define VIDEO_DRIVER "video4linux2"
+ #define DEFAULT_WEBCAM "/dev/video0"
+ #endif
diff --git a/net-im/tox/pkg-descr b/net-im/tox/pkg-descr
new file mode 100644
index 000000000000..f6cc7e9101fe
--- /dev/null
+++ b/net-im/tox/pkg-descr
@@ -0,0 +1,10 @@
+Tox is a decentralized, secure messenger with audio and video chat capabilities.
+You can see it as an alternative to Skype.
+
+This is only the core library. To use it, you have to install a client, like
+e.g. net-im/venom.
+
+Tox isn't complete yet, but we encourage you to contribute to help make us
+awesome!
+
+WWW: http://tox.im/
diff --git a/net-im/tox/pkg-plist b/net-im/tox/pkg-plist
new file mode 100644
index 000000000000..07b36a5b6eaf
--- /dev/null
+++ b/net-im/tox/pkg-plist
@@ -0,0 +1,13 @@
+bin/DHT_bootstrap
+include/tox/tox.h
+include/tox/toxav.h
+lib/libtoxav.a
+lib/libtoxav.la
+lib/libtoxav.so
+lib/libtoxav.so.0
+lib/libtoxcore.a
+lib/libtoxcore.la
+lib/libtoxcore.so
+lib/libtoxcore.so.0
+libdata/pkgconfig/libtoxcore.pc
+@dirrm include/tox