aboutsummaryrefslogtreecommitdiff
path: root/net-im/trix
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-07-26 19:19:20 +0000
committerRene Ladan <rene@FreeBSD.org>2013-07-26 19:19:20 +0000
commit66fee909266a1dedf3dfc1f03bb0841380d78805 (patch)
tree4c98d494bc4532b5dd5b19f4e47bcb3babf104c2 /net-im/trix
parenteec2cb8d7407c5628cc8016e7349abbee6c98e3f (diff)
downloadports-66fee909266a1dedf3dfc1f03bb0841380d78805.tar.gz
ports-66fee909266a1dedf3dfc1f03bb0841380d78805.zip
Notes
Diffstat (limited to 'net-im/trix')
-rw-r--r--net-im/trix/Makefile44
-rw-r--r--net-im/trix/distinfo2
-rw-r--r--net-im/trix/files/patch-settings.cpp17
-rw-r--r--net-im/trix/files/patch-xxxprotocol.cpp42
-rw-r--r--net-im/trix/files/patch-xxxprotocol.h14
-rw-r--r--net-im/trix/pkg-descr8
-rw-r--r--net-im/trix/pkg-plist121
7 files changed, 0 insertions, 248 deletions
diff --git a/net-im/trix/Makefile b/net-im/trix/Makefile
deleted file mode 100644
index be1abb135d0b..000000000000
--- a/net-im/trix/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# New ports collection makefile for: trix
-# Date created: 17 April 2008
-# Whom: Kozienko Aleksandr <pascalamsg@gmail.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= trix
-PORTVERSION= 0.94
-PORTREVISION= 5
-CATEGORIES= net-im
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= pascalamsg@gmail.com
-COMMENT= TriX is a chat compatible with 2.0 protocol of the Vypress Chat
-
-DEPRECATED= Broken on FreeBSD 8 and newer
-EXPIRATION_DATE=2013-09-01
-
-USE_QT_VER= 3
-USE_GMAKE= yes
-USE_PERL5= yes
-USE_XORG= xext
-GNU_CONFIGURE= yes
-USE_BZIP2= yes
-
-CONFIGURE_ARGS += --with-qt-dir=${QT_PREFIX} \
- --with-extra-includes=${LOCALBASE}/include \
- --with-extra-libs=${LOCALBASE}/lib
-
-.if !defined(WITHOUT_PLAY)
-BUILD_DEPENDS= play:${PORTSDIR}/audio/play
-.endif
-
-post-extract:
- ${CHMOD} 744 ${WRKSRC}/install-sh
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800059
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net-im/trix/distinfo b/net-im/trix/distinfo
deleted file mode 100644
index 113e94a7f79b..000000000000
--- a/net-im/trix/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (trix-0.94.tar.bz2) = 4ca2c49ebe0a422c0678212b2304b599c82542255fcf6add7efa548c7725ae5a
-SIZE (trix-0.94.tar.bz2) = 1018173
diff --git a/net-im/trix/files/patch-settings.cpp b/net-im/trix/files/patch-settings.cpp
deleted file mode 100644
index 64fcbd1f07e3..000000000000
--- a/net-im/trix/files/patch-settings.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/settings.cpp.orig 2008-06-29 20:24:50.000000000 +0300
-+++ src/settings.cpp 2008-07-02 18:31:27.000000000 +0300
-@@ -143,11 +143,10 @@
- def_downloadpath=QDir::homeDirPath();
- def_awaylimit=1800;
- def_autoupdateinterval = 300;
--#ifdef BSD
-+
- def_playcmd="/usr/local/bin/play";
--#else
-- def_playcmd = "/usr/bin/aplay";
--#endif
-+
-+
- def_snd[Sound::Chatline] = datapath + "snd/chatline.wav";
- def_snd[Sound::Beep] = datapath + "snd/beep.wav";
- def_snd[Sound::JoinChannel] = datapath + "snd/join.wav";
diff --git a/net-im/trix/files/patch-xxxprotocol.cpp b/net-im/trix/files/patch-xxxprotocol.cpp
deleted file mode 100644
index 5ae9e5b6e333..000000000000
--- a/net-im/trix/files/patch-xxxprotocol.cpp
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/xxxprotocol.cpp.orig 2008-06-29 19:17:33.000000000 +0100
-+++ src/xxxprotocol.cpp 2008-07-02 13:20:41.000000000 +0100
-@@ -8,6 +8,7 @@
- #include <quuid.h>
- #include <qsocketnotifier.h>
- #include <qmessagebox.h>
-+#include <sys/param.h>
- #include <sys/types.h>
- #include <sys/ioctl.h>
- #include <sys/socket.h>
-@@ -17,12 +18,11 @@
- #include <unistd.h>
- #include <fcntl.h>
-
--#ifdef FREEBSD
-+#ifdef BSD
- #include <err.h>
- #include <errno.h>
- #include <net/if.h>
- #include <sys/sysctl.h>
--#include <sys/param.h>
- #include <netinet/if_ether.h>
- #include <net/route.h>
- #include <net/if_dl.h>
-@@ -207,7 +207,7 @@
- QString XXXProtocol::getHWAddr(const QString& addr, const QString& iface)
- {
- QString macaddr(tr("Unknown"));
--#ifdef BSD
-+#if defined ( BSD )
- struct sockaddr_inarp addr_inarp;
-
- bzero(&addr_inarp, sizeof(addr_inarp));
-@@ -249,7 +249,7 @@
- return macaddr;
- }
-
--#ifdef BSD
-+#if defined ( BSD )
- struct sockaddr_dl * XXXProtocol::search(u_long addr)
- {
- int mib[6];
diff --git a/net-im/trix/files/patch-xxxprotocol.h b/net-im/trix/files/patch-xxxprotocol.h
deleted file mode 100644
index abb171bf0183..000000000000
--- a/net-im/trix/files/patch-xxxprotocol.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/xxxprotocol.h.orig 2008-06-29 18:29:01.000000000 +0100
-+++ src/xxxprotocol.h 2008-07-02 13:17:12.000000000 +0100
-@@ -31,9 +31,9 @@
- uint port;
- int recvsd; //UDP socket
-
--#ifdef BSD
-+
- struct sockaddr_dl *search(u_long addr);
--#endif
-+
-
- struct UserSpec {
- char codec;
diff --git a/net-im/trix/pkg-descr b/net-im/trix/pkg-descr
deleted file mode 100644
index 8487df383e2d..000000000000
--- a/net-im/trix/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-As compared to VyQChat in TriX such new features appears as:
-files transfer, bulletin board, users avatars, logs, links
-navigation, broadcast and multicast type of connection, search
-by IP address and many other, a few more features not listed here.
-Now TriX is compatible with the version 2.0 of the Vypress Chat
-protocol developed by VyPRESS Research.
-
-WWW: http://trix.sourceforge.net/
diff --git a/net-im/trix/pkg-plist b/net-im/trix/pkg-plist
deleted file mode 100644
index 9f58c1ab8d98..000000000000
--- a/net-im/trix/pkg-plist
+++ /dev/null
@@ -1,121 +0,0 @@
-bin/trix
-%%DATADIR%%/avatars/bird.gif
-%%DATADIR%%/avatars/blue_angel.jpg
-%%DATADIR%%/avatars/blue_sky.jpg
-%%DATADIR%%/avatars/dark.jpg
-%%DATADIR%%/avatars/dark_angel.jpg
-%%DATADIR%%/avatars/edward.gif
-%%DATADIR%%/avatars/female_face_1.jpg
-%%DATADIR%%/avatars/hand.jpg
-%%DATADIR%%/avatars/red.jpg
-%%DATADIR%%/avatars/tekila.jpg
-%%DATADIR%%/avatars/white_angel.jpg
-%%DATADIR%%/gfx/about.png
-%%DATADIR%%/gfx/angel.png
-%%DATADIR%%/gfx/angry.png
-%%DATADIR%%/gfx/automessage.png
-%%DATADIR%%/gfx/bat.png
-%%DATADIR%%/gfx/beep.png
-%%DATADIR%%/gfx/beer.png
-%%DATADIR%%/gfx/boardnormal.png
-%%DATADIR%%/gfx/cake.png
-%%DATADIR%%/gfx/cat.png
-%%DATADIR%%/gfx/cbblank.png
-%%DATADIR%%/gfx/cbchecked.png
-%%DATADIR%%/gfx/chnlalert.png
-%%DATADIR%%/gfx/chnlnormal.png
-%%DATADIR%%/gfx/clear.png
-%%DATADIR%%/gfx/clock.png
-%%DATADIR%%/gfx/cocktail.png
-%%DATADIR%%/gfx/colors.png
-%%DATADIR%%/gfx/confused.png
-%%DATADIR%%/gfx/copy.png
-%%DATADIR%%/gfx/cry.png
-%%DATADIR%%/gfx/cup.png
-%%DATADIR%%/gfx/decrypted.png
-%%DATADIR%%/gfx/default.png
-%%DATADIR%%/gfx/devil.png
-%%DATADIR%%/gfx/dog.png
-%%DATADIR%%/gfx/down.png
-%%DATADIR%%/gfx/downarrows.png
-%%DATADIR%%/gfx/dude_hug.png
-%%DATADIR%%/gfx/edit.png
-%%DATADIR%%/gfx/editclear.png
-%%DATADIR%%/gfx/editcut.png
-%%DATADIR%%/gfx/editpaste.png
-%%DATADIR%%/gfx/embarassed.png
-%%DATADIR%%/gfx/encrypted.png
-%%DATADIR%%/gfx/exit.png
-%%DATADIR%%/gfx/female.png
-%%DATADIR%%/gfx/film.png
-%%DATADIR%%/gfx/find.png
-%%DATADIR%%/gfx/fonts.png
-%%DATADIR%%/gfx/forward.png
-%%DATADIR%%/gfx/gear.png
-%%DATADIR%%/gfx/girl_hug.png
-%%DATADIR%%/gfx/info.png
-%%DATADIR%%/gfx/kiss.png
-%%DATADIR%%/gfx/leave.png
-%%DATADIR%%/gfx/lightbulb.png
-%%DATADIR%%/gfx/locale.png
-%%DATADIR%%/gfx/logo.png
-%%DATADIR%%/gfx/love.png
-%%DATADIR%%/gfx/mail.png
-%%DATADIR%%/gfx/male.png
-%%DATADIR%%/gfx/massmessage.png
-%%DATADIR%%/gfx/message.png
-%%DATADIR%%/gfx/network.png
-%%DATADIR%%/gfx/new.png
-%%DATADIR%%/gfx/normal.png
-%%DATADIR%%/gfx/notify.png
-%%DATADIR%%/gfx/omg.png
-%%DATADIR%%/gfx/phone.png
-%%DATADIR%%/gfx/photo.png
-%%DATADIR%%/gfx/present.png
-%%DATADIR%%/gfx/prvalert.png
-%%DATADIR%%/gfx/prvnormal.png
-%%DATADIR%%/gfx/refresh.png
-%%DATADIR%%/gfx/rose.png
-%%DATADIR%%/gfx/sad.png
-%%DATADIR%%/gfx/save.png
-%%DATADIR%%/gfx/saveas.png
-%%DATADIR%%/gfx/saynick.png
-%%DATADIR%%/gfx/send.png
-%%DATADIR%%/gfx/settings.png
-%%DATADIR%%/gfx/shade.png
-%%DATADIR%%/gfx/sleep.png
-%%DATADIR%%/gfx/smile.png
-%%DATADIR%%/gfx/smiletris.png
-%%DATADIR%%/gfx/sound.png
-%%DATADIR%%/gfx/star.png
-%%DATADIR%%/gfx/switchuser.png
-%%DATADIR%%/gfx/sysmsg.png
-%%DATADIR%%/gfx/teeth.png
-%%DATADIR%%/gfx/thumbs_down.png
-%%DATADIR%%/gfx/thumbs_up.png
-%%DATADIR%%/gfx/tongue.png
-%%DATADIR%%/gfx/trash.png
-%%DATADIR%%/gfx/trayntfy.png
-%%DATADIR%%/gfx/unlove.png
-%%DATADIR%%/gfx/uparrows.png
-%%DATADIR%%/gfx/useraway.png
-%%DATADIR%%/gfx/userdnd.png
-%%DATADIR%%/gfx/useroffline.png
-%%DATADIR%%/gfx/users.png
-%%DATADIR%%/gfx/wilted_rose.png
-%%DATADIR%%/gfx/wink.png
-%%DATADIR%%/gfx/xedit.png
-%%DATADIR%%/snd/beep.wav
-%%DATADIR%%/snd/chatline.wav
-%%DATADIR%%/snd/join.wav
-%%DATADIR%%/snd/leave.wav
-%%DATADIR%%/snd/message.wav
-%%DATADIR%%/tr/trix_bg.qm
-%%DATADIR%%/tr/trix_en.qm
-%%DATADIR%%/tr/trix_ru.qm
-%%DATADIR%%/tr/trix_sp.qm
-@dirrm %%DATADIR%%/tr
-@dirrm %%DATADIR%%/snd
-@dirrm %%DATADIR%%/gfx
-@dirrm %%DATADIR%%/avatars
-@dirrm %%DATADIR%%