aboutsummaryrefslogtreecommitdiff
path: root/net-im/twitmail/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-13 22:03:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-13 22:03:39 +0000
commitb1d084e0c3ec8bd39aeb3db9bb1fe6a1230b4b43 (patch)
tree9f0f046df83b113d0b0b10beb94f489aa29dae80 /net-im/twitmail/Makefile
parentcb12efe47c61dd95a1a04f376d283f446f1e7cb5 (diff)
downloadports-b1d084e0c3ec8bd39aeb3db9bb1fe6a1230b4b43.tar.gz
ports-b1d084e0c3ec8bd39aeb3db9bb1fe6a1230b4b43.zip
Notes
Diffstat (limited to 'net-im/twitmail/Makefile')
-rw-r--r--net-im/twitmail/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-im/twitmail/Makefile b/net-im/twitmail/Makefile
new file mode 100644
index 000000000000..28a51e41af51
--- /dev/null
+++ b/net-im/twitmail/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: twitmail
+# Date created: 2010-02-13
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twitmail
+PORTVERSION= 0.42
+CATEGORIES= net-im perl5
+MASTER_SITES= http://www.hardakers.net/twitmail/releases/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Curses-based mail-like interface to twitter
+
+BUILD_DEPENDS= p5-DBD-SQLite>=1.12:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBI>=1.60.4:${PORTSDIR}/databases/p5-DBI \
+ p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
+ ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
+ p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-Net-Twitter>=3.04002:${PORTSDIR}/net/p5-Net-Twitter \
+ p5-TimeDate>=2.24:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Getopt-GUI-Long>=0.91:${PORTSDIR}/devel/p5-Getopt-GUI-Long
+
+PERL_CONFIGURE= yes
+
+MAN1= twitmail.1
+
+.include <bsd.port.mk>