aboutsummaryrefslogtreecommitdiff
path: root/net-im/vacuum-im
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-04 14:10:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-04 14:10:25 +0000
commitf801af2e451eccc3a0c944fa81e1291c1c4822f8 (patch)
tree6a0dafe286187d1bc69dfc9125ddb13a0a3d43ff /net-im/vacuum-im
parent7b5106f28473ecca2c995d7d5a301aa5cd22924b (diff)
downloadports-f801af2e451eccc3a0c944fa81e1291c1c4822f8.tar.gz
ports-f801af2e451eccc3a0c944fa81e1291c1c4822f8.zip
net-im/vacuum-im: Fix build with Clang 6
src/plugins/filemessagearchive/filemessagearchive.cpp:514:24: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal] QFile log(dirPath+"/"LOG_FILE_NAME); ^ ... and many more like these later http://beefy11.nyi.freebsd.org/data/head-i386-default/p478648_s338416/logs/errors/vacuum-im-1.2.5.log
Notes
Notes: svn path=/head/; revision=478961
Diffstat (limited to 'net-im/vacuum-im')
-rw-r--r--net-im/vacuum-im/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net-im/vacuum-im/Makefile b/net-im/vacuum-im/Makefile
index 6c7e78f36c16..e72b78352727 100644
--- a/net-im/vacuum-im/Makefile
+++ b/net-im/vacuum-im/Makefile
@@ -17,6 +17,7 @@ GH_ACCOUNT= Vacuum-IM
GH_PROJECT= ${PORTNAME}${PKGNAMESUFFIX}
USES= cmake qt:4
+USE_CXXSTD= c++98
USE_XORG= xscrnsaver
USE_LDCONFIG= yes
USE_QT= gui xml qmake_build uic_build moc_build rcc_build \